Question

Error with ProFTPD and .conf file

In installed ProFTPD on my cloud (immobiliaremagia - 192.241.191.93), but when i restart the FTP i have this message:


warning: unable to determine IP address of ‘immobiliaremagia’ error: no valid servers configured Fatal: error processing configuration file ‘etc/proftpd/proftpd.conf’ [fail]


I modifyed the conf file uncommenting the row with DEFAULTROOT and I wrote:

ServerName “192.241.191.93”

the I changed and I wrote

ServerName “immobiliaremagia”

but in both cases I had the same error message. What can I do? THANKS

Subscribe
Share

I have immobiliaremagia.it as domain, and I have a redirect to Digital Ocean at this IP: 192.241.191.93 I need to access Digital Ocean files and i don’t know hou to do this. I installed the FTP, but it doesn’t work. This is my problem THANKS

Is immobiliaremagia.it hosted on a single server? What happens when you replace ServerName "immobiliaremagia with the IP of the server that is hosting immobiliaremagia.it ? It looks like the previous IP you had for your server was actually your local IP.

Hi, What is the FQDN, or fully-qualified domain name for your server? This would look like immobiliaremagia.something.com


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi!

FTP is an inherently insecure protocol. By default, unless FTPS is implemented, all credentials are sent in plaintext over an unencrypted connection. As a result of that, almost all FTP servers block root access entirely.

I would recommend uninstalling ProFTPD and connecting via SFTP, which is a completely separate file transfer protocol, that relies on SSH for authentication and encryption. You should be able to do that simply by setting your client to use SFTP and connect to port 22 and using your already existing SSH credentials to authenticate. Here’s a tutorial on using FileZilla to transfer files via SFTP.

Alternatively, if you absolutely need to use FTP, the ServerName directive only changes the text that appears when you connect to the FTP server, so that shouldn’t cause any errors. Try adding the following line to /etc/hosts and restarting ProFTPD:

127.0.0.1 immobiliaremagia