Errors in the guide for setting up user quotas on Ubuntu 14.04?

June 20, 2016 949 views
Getting Started System Tools Ubuntu

Following this guide: https://www.digitalocean.com/community/tutorials/how-to-enable-user-and-group-quotas

Everything seems to work until this step:

quotacheck -cum /

The error text I received is:

quotacheck: Mountpoint (or device) / not found or has no quota enabled.
quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.

I tried edquota some_user, just to see if I could get any further. The error for that was:

No filesystems with quota detected.

I'm pretty clueless with all of this, so I'd appreciate any help.

Thanks!

1 Answer

Could you show us the output of cat /etc/fstab; mount ?

  • # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    # / was on /dev/vda1 during installation
    UUID=REDACTED /               ext4    errors=remount-ro 0       1
    LABEL=DOROOT                  /           ext4    errors=remount-ro,usrquota  0 1
    
    /dev/vda1 on / type ext4 (rw,errors=remount-ro)
    proc on /proc type proc (rw,noexec,nosuid,nodev)
    sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
    none on /sys/fs/cgroup type tmpfs (rw)
    none on /sys/fs/fuse/connections type fusectl (rw)
    none on /sys/kernel/debug type debugfs (rw)
    none on /sys/kernel/security type securityfs (rw)
    udev on /dev type devtmpfs (rw,mode=0755)
    devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
    tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
    none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
    none on /run/shm type tmpfs (rw,nosuid,nodev)
    none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
    none on /sys/fs/pstore type pstore (rw)
    systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd)
    

    I removed the value for the UUID above, since I didn't know if it was sensitive or not. Other than that, the output above was untouched.

    • Remove the entire LABEL=DOROOT line and add the usrquota option to the line defining the mount point for / (UUID=...)

      Also, it's never a good idea to redact troubleshooting information, especially if you don't know if it's sensitive or not. If it's not a password, it's probably not sensitive.

      • Thank you for the help! I see what I did wrong now.

        • Essentially the tutorial expects you to modify the line, not add a new one.

          Those lines are mount point definitions for your system.

          Good luck.

Have another answer? Share your knowledge.