Question

Errors When Installing a Certificate Using Certbot

Posted March 24, 2020 192 views
UbuntuSecurity

Hi, I am using Certbot to install an SSL certificate for my new site. I run the command below:

 sudo /usr/local/bin/certbot-auto --nginx

And I get the errors listed below:

E: Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/p/python2.7/python2.7_2.7.16-2~18.10_amd64.deb  404  Not Found [IP: 104.24.116.209 80]
E: Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/o/openssl/libssl-dev_1.1.1-1ubuntu2.2_amd64.deb  404  Not Found [IP: 104.24.116.209 80]
E: Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/o/openssl/libssl1.1_1.1.1-1ubuntu2.2_amd64.deb  404  Not Found [IP: 104.24.116.209 80]
E: Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/p/python2.7/libpython2.7-stdlib_2.7.16-2~18.10_amd64.deb  404  Not Found [IP: 104.24.116.209 80]
E: Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/p/python2.7/python2.7-minimal_2.7.16-2~18.10_amd64.deb  404  Not Found [IP: 104.24.116.209 80]
E: Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/p/python2.7/libpython2.7-minimal_2.7.16-2~18.10_amd64.deb  404  Not Found [IP: 104.24.116.209 80]
E: Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/o/openssl/openssl_1.1.1-1ubuntu2.2_amd64.deb  404  Not Found [IP: 104.24.116.209 80]
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/a/augeas/augeas-lenses_1.10.1-2_all.deb  404  Not Found [IP: 104.24.116.209 80]
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/universe/a/augeas/libaugeas0_1.10.1-2_amd64.deb  404  Not Found [IP: 104.24.116.209 80]
E: Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/p/python2.7/libpython2.7_2.7.16-2~18.10_amd64.deb  404  Not Found [IP: 104.24.116.209 80]
E: Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/p/python2.7/libpython2.7-dev_2.7.16-2~18.10_amd64.deb  404  Not Found [IP: 104.24.116.209 80]
E: Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/p/python-defaults/libpython2-dev_2.7.15-3_amd64.deb  404  Not Found [IP: 104.24.116.209 80]
E: Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/p/python-defaults/libpython-dev_2.7.15-3_amd64.deb  404  Not Found [IP: 104.24.116.209 80]
E: Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/p/python2.7/python2.7-dev_2.7.16-2~18.10_amd64.deb  404  Not Found [IP: 104.24.116.209 80]
E: Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/p/python-defaults/python2-dev_2.7.15-3_amd64.deb  404  Not Found [IP: 104.24.116.209 80]
E: Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/p/python-defaults/python-dev_2.7.15-3_amd64.deb  404  Not Found [IP: 104.24.116.209 80]
E: Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/p/python-setuptools/python-pkg-resources_40.2.0-1_all.deb  404  Not Found [IP: 104.24.116.209 80]

It looks like it might be an issue with Digital Ocean. Please can someone look into it.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi there @cbriant,

I would recommend trying to update your local repository:

  • sudo apt update -y

The packages that you are looking for seem not to be available anymore.

Let me know how it goes!
Regards,
Bobby

Submit an Answer