Question

Estoy intentando instalar algunos paquetes de Nginx pero me topo con este error.¿ Que podria estar pasando?

Posted November 19, 2019 394 views
NginxLinux CommandsUbuntu 18.04
apt-get install nginx-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 nginx : Depends: nginx-core (< 1.14.0-0ubuntu1.6.1~) but it is not going to be installed or
                  nginx-full (< 1.14.0-0ubuntu1.6.1~) but it is not going to be installed or
                  nginx-light (< 1.14.0-0ubuntu1.6.1~) but it is not going to be installed or
                  nginx-extras (< 1.14.0-0ubuntu1.6.1~) but it is not going to be installed
         Depends: nginx-core (>= 1.14.0-0ubuntu1.6) but it is not going to be installed or
                  nginx-full (>= 1.14.0-0ubuntu1.6) but it is not going to be installed or
                  nginx-light (>= 1.14.0-0ubuntu1.6) but it is not going to be installed or
                  nginx-extras (>= 1.14.0-0ubuntu1.6) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
edited by bobbyiliev

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hello,

I would suggest trying to run this command:

apt --fix-broken install

as suggested in the output.

Let me know how it goes!
Regards,
Bobby

Submit an Answer