Exim4 not sending mail if recipient is on the same domain as the website.

  • Posted January 26, 2015

Exim seems to be “delivering” mail locally if the recipient is on the same domain as the webserver. How do I force exim to always send out the mail?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Had the same issue. Here’s what I did to troubleshoot.

See where it fails by running (change to your destination)

exim -bt

Check if your hosts are getting resolved properly by running these commands on the terminal.

# the following should show the short 'hostname'

# following should show the full domain name (without www or subdomains)
hostname --fqdn

# following should show the external IP (not
hostname -i

If all is good, and if the block is still unroutable, force the exim configuration to route it. So edit /etc/exim/exim4.conf.template file, and find the block within .ifdef DCconfig_internet. Add this as the first rule. (Change to your domain)

  debug_print = "R: dnslookup for $local_part@$domain"
  driver = dnslookup
  domains =
  transport = remote_smtp
  # ignore private rfc1918 and APIPA addresses
  ignore_target_hosts = : : :\
               : : :\

Run the routing test again to see if it passes now.

Note about exim4.conf.template file. This can get regenerated if you run the config utility again. To avoid this, duplicate this change in the /etc/exim/conf.d/routing/ folder as well.

I was able to resolve this issue, I had inadvertently set the hostname to the domain name. Setting the hostname to: and then reconfiguring exim fixed the issue.