Hi All
I have a kubernetes instance in digital ocean, i have configured ingress correctly with nginx and everything that work as http work well.
No i have to expose a TCP port ( the protocol used is called bold, I’m not sure if this protocol use WebSockets or not ), the port is 7687.
With a classic ingress, the driver fail to connect with the database ( Neo4J ).
How i can open a TCP port outside?

thanks in advance

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

@cingusoft I recommend using one of the following approaches for getting Neo4j properly setup within your Kubernetes Cluster:

Another option would be to use the Neo4j K8s operator which can be found at the following location:

Finally, the Neo4j K8s operator is currently within its alpha phase of software development. Thus, it may be better to use Neo4j Helm Chart at this time.

Think different and code well,

-Conrad

Hi @conradwt
thanks for your reply

I have already configured NEO4J in the cluster and work like a charm, the problem is with port 7687 externally exposed.
I mean, i need to open and external port from the load balancer and the nginx-ingress to access to the NEO4J service.

Submit an Answer