ext4 filesystem "needs journal recovery"

I have errors from grub-emu:

error: sparse file not allowed.
error: no such device: 21b294f1-25bd-4265-9c4e-d6e4aeb57e97.
error: can't find command `linux'.
error: can't find command `initrd'.

If I run file -s /dev/sda, I see:

/dev/sda: Linux rev 1.0 ext4 filesystem data, UUID=6e1fd477-4aec-4323-83b8-55c419ce471f (needs journal recovery) (extents) (64bit) (large files) (huge files)

This is very worrying because I can’t reboot the machine, what can I do?

I also posted this question to

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I solved this grub / btrfs issue with GRUB_DEFAULT=“1” to boot the 2nd kernel in the GRUB menu