Extra Wordpress website on a sub-domain using NGINX (LEMP)

May 8, 2014 3.1k views
https://www.digitalocean.com/community/articles/how-to-install-wordpress-with-nginx-on-ubuntu-12-04 I did this installation few months ago and everything worked fine! Thank you guys! Later I have changed mymaindomain.com website from "/var/www/" to "/var/www/mymaindomain" -- I did change the root on nginx configuration files and everything worked! :) Now I did repeat the same Wordpress instillation for a second website. This one, I want it to be on a subdomain like this: sub.mymaindomain.com. So I have repeated the Wordpress installation on this folder "/var/www/SUBmymaindomain", and created a new Set Up Nginx Server Blocks file with a different name for this website: server { listen 80; root /var/www/SUBmymaindomain; index index.php index.html index.htm; server_name sub.mymaindomain.com; (...) After this I did activate the Server Block with a new symbolic link and so on... But it seams that's not enough to make it working. Do i need to do any changes on DigitalOcean DNS setting? Thank you guys!
4 Answers
Within DNS, create a CNAME record with the name as your subdomain, for example "subdomain" for subdomain.maindomain.com. For the hostname, you can put "@" or "maindomain.com".
Looks like you're on the right path, but you will need to make a DNS change to get subdomains working. You need to set a CNAME record. If you don't have subdomains running on a different server, the simplest thing to do is to just set a wildcard CNAME pointing to the main IP:

* -- CNAME -- @

Then you can create as many subdomains as you need on that server without touching DNS again.

Check out:

by Assaf Gordon
Here's some documentation on how to set up and test DNS subdomains with DigitalOcean's DNS panel.
Thank you a lot @Aidhan and @Andrew SB!

Since my subdomain is going to be pro.mydomain.com, what's the best solution:

pro -- CNAME -- @ , like this: http://imagizer.imageshack.us/a/img836/9021/bpxh.png


* -- CNAME -- @ , like this: http://imagizer.imageshack.us/a/img834/5687/gvun.png


one more question: is the "www -- CNAME - @" a problem? should i remove it? is there something wrong with my DNS configuration?

Thank you again for your time -- I really hope my question can help also other DigitalOcean users!
I went for the "* -- CNAME -- @" and i erased the "www -- CNAME - @" which worked as expected.. ;) thank you!
Have another answer? Share your knowledge.