Facing issue while installing node on droplet

July 15, 2017 680 views


I am following link to deploy my node application to digital ocean.
But when I am trying to install node using curl I am getting the following exception,

E: Failed to fetch Hash Sum mismatch
E: Failed to fetch 404 Not Found [IP: 80]
E: Failed to fetch 404 Not Found [IP: 80]
E: Failed to fetch 404 Not Found [IP: 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
Error executing command, exiting.

I connected the server using ubuntu's console with authentication and also using ssh, but this problem is still persisting.

Also tried removing var/lists directory and then tried to install node using apt-get but the didn't succeeded.

Also can you please give me some link to deploy bitbucket repository on digital ocean ?

Thanks in advance.

1 comment
  • @snjdb1

    It seems this issue is related to digitalocean servers, it works for me on my own server outside digitalocean maybe open a support ticket.

1 Answer


Usually, a 404 error means that your package index list is outdated. Run sudo apt-get update to refresh the index and download the latest info from your repositories. Then, you should be able to re-run the apt-get install ... command that failed.

Have another answer? Share your knowledge.