Failed to establish a connection to the console. Please reload.

Posted November 6, 2014 17.2k views

I get this error message when I click on “Console Access” button inside my droplet. Anyone has any idea about this error?


These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

20 answers

There seems to be quite a lot of people with this same issue. There comes a time when “open a ticket” is not good enough for subscribing users. How many people does Digital Ocean need with the same problem before they actually realize it may be more than a single users issue?
I have the same issue exactly after creating a brand new droplet, and the only support I find is the same issue reported by other users repeatedly, do you think it may be actually a problem with Digital Ocean (perish the thought)??

Same here, and quite frustrating.

Everytime this error has happened to me, it has been due to a firewall. Check to make sure that ports 6000-7000 are being allowed through.


This is usually a very temporary error, and should be resolved by reloading the page. If it continues, please open a support ticket so the team can investigate the issue and get you back up and running.

I start having the same issue with one of my droplets.
I created a ticket, but the support wasn’t able to find any issues.

At one point the server became accessible.

Today I get the same issue. The site is down, the droplet is not accessible by admin console or by ssh.

I resized the droplet, that didn’t help.

same issue happens to me

it’s just keeps happening to me again and again resulting in hours of downtime.
This is unacceptable for a production environment.

Oh no! No access for me. I tried using putty both with and without ssh, as well as the Digital Ocean console and nothing is working. I have not changed anything - it was working 2 days ago when I last checked. Today I was planning to create a Mean stack setup on a new droplet - but nothing is working and I cannot access my existing droplets either. What is going on, have they changed something at Digital Ocean???

  • I have the same problem, I created a support ticket but all there responses are obvious things that I have already tried.

    For me this issue has ready happened twice on different droplets.

    Here is one of the feedback:
    Hey there,

    Actually, here is my usual list of things that inhibit console access:

    1. If you are behind a restrictive firewall. opening ports 6000-7000 will usually clear this up.
    2. If you are on a network with a double-NAT configuration.
    3. If you are behind a web-proxy (almost all mobile broadband connections configure a proxy).
    4. If you are on a satellite or other high latency connection as this can cause timeouts.
    5. If all of the above fail, try from a different browser / device / network to see if that helps clear up the issue. As I have often seen simply changing one of these variables resolve the issue. Once we narrow the scope by knowing what fixes the issue, we can further investigate.

    Ethan Fox
    Platform Support Specialist - DigitalOcean

Has there been any resolution to this problem??? I need help to resolve this and doesn’t seem like DO is doing there part.

Same problem by us as well. It was completely fine until this morning. This issue MUST be addressed and it is NOT acceptable for a production environment.

I have exactly the same issue.
This is not good service

I have the same problem :(

Is this going to be resolved :(

I am getting this now :(

I just started having this problem while in the middle of fixing a cron job. Reloading does not help. Trying another browser does not help.

Its been the same for the past 30 minutes . Such a cheap service !

Same issue after a scheduled backup.
Tried to reload the page but it doesn’t help. :(
Gonna open a ticket !!

I’ve shutdown and restarted the VPS.
Now everything (ssh,VNC-access) is OK!
Didn’t imagine such windows-problem-solving-strategy could work in linux-like envs too.. :P

I’ve seen ports 6000:7000 mentioned, but inspecting browser javascript errors I found that opening port 5000 was necessary and solved this for me. However, I could always connect with SSH, just not the DigitalOcean console.

Same issue. I couldn’t access via SSH or via Digital Ocean control panel. I did a hard reset in the control panel but that didn’t work. I then clicked shut down to power it off then turned it back on and I can now SSH in. RESOLVED.

I used to face the same problem sometimes only. Today, I was not able to gain access since 6 hours.

Submit an Answer