Question

Failed to Migrate Wordpress using Migrate Guru

Hi, i tried to migrate a wordpress site from a temporary hosting to Digital Ocean.

I tried using SFTP, and used the private SSH key.

However it failed, stating

Migration Failed

Incorrect Username/Password. Please confirm FTP/SFTP login credentials first and retry.

Source :http://139.59.101.80

Destination :http://tourplus.my

I can login to Filezilla using the public key just fine. Even my dev failed to connect using the private key.

Is there any setting we’re configured wrongly?

Last time when i used migrate guru to migrate to lightsail server using the same way, it works fine.

Hope you guys can help.

Thank you

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello there,

We do have an article that covers the process, although it is with deprecated status, however, you can check it here:

https://www.digitalocean.com/community/tutorials/how-to-migrate-wordpress-from-shared-hosting-to-a-cloud-server-with-zero-downtime

You can use the WP All in One plugin or Duplicator to migrate all of your WordPress websites.

https://wordpress.org/plugins/all-in-one-wp-migration/

https://wordpress.org/plugins/duplicator/

If you have to move some of the data manually you can do that via ssh using scp or rsync. Another option is to use an FTP client like FileZilla

https://www.digitalocean.com/community/tutorials/how-to-copy-files-with-rsync-over-ssh

https://docs.digitalocean.com/products/droplets/how-to/transfer-files/

Hope that this helps!

Hello,

It sounds like Migrate Guru is not trying to use the SSH key but is defaulting to SSH password as the authentication method.

You could enable password authentication by opening the /etc/ssh/sshd_config file using your preferred text editor, like nano or vim. Find the line that reads PasswordAuthentication no line and change it to PasswordAuthentication yes, then save and exit the file and restart the SSH service with systemctl restart ssh.

Then try using your SSH password and username instead.

Hope that this helps. Regards, Bobby