Question

file_get_contents Remote Server Access Your server is blocking "Remote Server Connection"

Posted June 5, 2019 838 views
PHP WordPress

Getting the following error:
filegetcontents Remote Server Access
Your server is blocking “Remote Server Connection”. Please contact your host provider to allow “filegetcontents” php function.

Wordpress, trying to get a YouTube gallery working.

Thanks for any input!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

1 answer

You would generally need to adjust your php configuration to allow_url_fopen.

https://www.php.net/manual/en/filesystem.configuration.php#ini.allow-url-fopen

There is a DO Community Tutorial that may assist you.

https://www.digitalocean.com/community/tutorials/how-to-change-your-php-settings-on-ubuntu-14-04

by Jon Schwenn
PHP is a server side scripting language used by many popular CMS and blog platforms like WordPress and Drupal. It is also part of the popular LAMP and LEMP stacks. Updating the PHP configuration settings is a common task when setting up a PHP-based website. This guide will show how to view the current PHP configuration settings of your web server and how to make updates to the PHP settings.
Submit an Answer