Question

Files created through sFTP are always 777

Hi :) I followed these two tutorials to setup my Server:

https://www.digitalocean.com/community/articles/initial-server-setup-with-ubuntu-12-04 https://www.digitalocean.com/community/articles/how-to-install-linux-nginx-mysql-php-lemp-stack-on-ubuntu-12-04

I want to login to the server with my IDE (Aptana) and create/edit/delete files:

sudo chown -R my-user:www-data /folder-name

This worked, I was able to create files and folders, but these folders all have the 777 file permissions. Is there a way to change this behavior so instead they are created with 755?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

You should be able to change the default file permissions for files created with Aptana via sftp in the its preferences dialog. Check the settings in <code> Aptana Studio > Publishing > FTP</code>