I am running wordpress on ubuntu 18 in digitalocean and trying connect using filezilla with sftp protocol.I am using root user with password.The problem is i am always getting following error

Status: Connecting to my_ip...
Response:   fzSftp started, protocol_version=9
Command:    open "root@my_ip" 22
Error:  FATAL ERROR: Network error: Connection timed out
Error:  Could not connect to server

In digitalocean access console i run

sftp root@myip

and get message

connected to my_ip

then run following commands

netstat -plunt | grep 22

output : [https://i.imgur.com/0oubnsS.png]

ss -nlput | grep sshd

output : [https://i.imgur.com/zkKAKzk.png]

ssh -p 22 root@my_ip

output: [https://i.imgur.com/vJ1lLTP.png]

tail -f /var/log/auth.log

output : [https://i.imgur.com/YfpGCn1.png]

ufw status

output: status:inactive

iptables --list

output: [https://i.imgur.com/SCc3VO6.png]

nano /etc/ssh/sshd_config

and find following rules

ForwardX11 yes
passwordAuthentication yes
#PubkeyAuthentication yes
#port 22

I also tried to login using putty but got network error “connection time out”

so how to solve this problem so that i can login using filezilla sftp protocol?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hello, @freshuser

Could you please let me know if you’ve disabled the Password Authentication for your droplet? If that is correct you wont be able to connect using the password in FileZilla. You can add your key to FileZilla in order to make this work.

You can check our tutorial on how to use FileZilla to transfer files.

https://www.digitalocean.com/community/tutorials/how-to-use-filezilla-to-transfer-and-manage-files-securely-on-your-vps

Hope this helps! Let me know how it goes.

Regards,
Alex

by Pablo Carranza
This article will teach you how to use Filezilla to transfer and manage files securely on your VPS.
  • Password Authentication yes
    
    

    i can login if i change my ip

    i have also checked whether my ip is blocked in fail2ban but no my ip was not there!!

    • Hello, @freshuser

      Could you please confirm that you’re unable to connect only via certain IP address and this is working completely fine when you try connecting from different network?

      is UFW enabled on your droplet?

      Let me know how it goes.

      Regards,
      Alex

Submit an Answer