Question

Firewall: External Content Blocked

  • Posted August 6, 2013

I followed the firewall guide here: https://www.digitalocean.com/community/articles/how-to-setup-a-basic-ip-tables-configuration-on-centos-6

However, I’m not able to view images from other websites and recaptcha cannot connect to validate captcha input.

http://www.google.com/recaptcha/api/verify

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Awesome, glad to hear that! :]

dodgy perl module, fixed image issue now, thanks :)

This is how I’m trying to get the images (Perl) <br> <br>my $img = LWP::UserAgent->new->request(new HTTP::Request GET => $url); <br> <br>$img->is_success is always false <br> <br>This used to work fine on my old server so I’m not sure what’s going on, any ideas?

It must be a configuration issue. Disabling iptables didn’t fix it therefore the firewall isn’t blocking it :]

Recaptcha and external images used to work fine on my old shared hosting, so it must be some configuration issue?

Is a recaptcha-not-reachable error from the ReCaptcha.pm perl module. I’ve tried a number of verify URLs including <br> <br>http://www.google.com/recaptcha/api/verify <br>http://api-verify.recaptcha.net

the issue of not being able to load the images* <br> <br>the command worked fine <br>iptables: Flushing firewall rules: [ OK ] <br>iptables: Setting chains to policy ACCEPT: filter [ OK ] <br>iptables: Unloading modules: [ OK ] <br>

I did <br> <br>sudo service iptables stop <br> <br>and the issue remains, is that the same thing as you suggested trying?

Run this command then: <br> <br><pre>sudo su -c “iptables-save > ~/iptables_backup && iptables -F” root</pre>

I get permission denied on that statement even when I sudo