First time setting up dokku, issue with user/permission

  • Posted May 18, 2014

HI, so I was following the tutorial to deploy a Flask application on dokku ( My app currently runs fine on Heroku so I think the settings etc should be good.

However I run into an issue when I wanted to add the remote (last step), it’s asking me for dokku@my_domain’s password. I didn’t explicitly set up the user dokku so I don’t know what the password is.

Sorry if this is a n00b question. Thanks for the help!


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

It sounds like your SSH key wasn’t added to the Dokku user. When you first setup the Dokku server, enter its IP address in a web browser to add your SSH public key. It should look like: <br> <br> <br> <br>To manually add another key latter, from your local machine you can run: <br> <br><pre> <br>cat ~/.ssh/ | ssh root@your.dokku.instance “sudo sshcommand acl-add dokku [description]” <br></pre>

sorry I followed that but I’m still not sure where I messed up. Is it on the my git host side or on my digitial ocean set up side? Thanks!

This is the issue with your ssh-key. Check if you added the right ssh-key. See this article for more details: