First time usage, unable to SSH

March 14, 2017 72 views
PHP Arch Linux

I have created and recreated to my hearts content, but I cant SSH

~/Documents/Projects/dev/laravel/api-stats master*
❯ ssh root@198.211.97.69
Permission denied (publickey).

I have also tried

~/Documents/Projects/dev/laravel/api-stats master*
❯ ssh root:<password>@198.211.97.69
Permission denied (publickey).

What is the correct method for ssh connection

What IP is the correct one?

198.211.97.xx or (10.136.16.xxx)

1 Answer

@Codedungeon

To specify an SSH key when using ssh, you need to use the -i argument.

i.e.

ssh root@198.211.97.69 -i /path/to/private_key

Without -i, you have to provide a password (i.e. the password associated with the users' account). If passwords are disabled (which is the case most of the time when SSH keys are used), then you will only be able to login with the private key.

Have another answer? Share your knowledge.