Flask-Rest unable to load configuration from uwsgi...postman 404 Not Found

February 23, 2018 1k views
API MySQL PHP Nginx Python Frameworks Ubuntu 16.04

Im trying to deploy Flask-restfull Api in Digitalocean platform i installed phpmyadmin,nginx,mysqlserver and php in ubuntu 16.04.3 x64 based on this tutorial here after that i can access my db from browser and login to it successfully ..The Problems Appeard after i run the uwsgi.service..the postman display this error 404 Not Found nginx/1.10.3 (Ubuntu) also i cant access phpmyadmin from browser.

what i did: from logs WARNING i knew that uwsgi should run as root i searched but nothing usefull....any help?? thanks in advance...the Errors and WARNING log file:-

Starting uWSGI 2.0.16 (64bit) on [Thu Feb 22 19:36:50 2018]
compiled with version: 5.4.0 20160609 on 22 February 2018 16:38:36
os: Linux-4.4.0-112-generic #135-Ubuntu SMP Fri Jan 19 11:48:36 UTC 2018
nodename: Flask-Api-Test
machine: x86_64
clock source: unix
detected number of CPU cores: 1
current working directory: /
detected binary path: /var/www/html/items-rest/venv/bin/uwsgi
!!! no internal routing support, rebuild with pcre support !!!
dropping root privileges as early as possible
uWSGI running as root, you can use --uid/--gid/--chroot options
*** WARNING: you are running uWSGI as root !!! (use the --uid flag) ***
your processes number limit is 3913
your memory page size is 4096 bytes
*** WARNING: you have enabled harakiri without post buffering. Slow upload could be rejected on post-unbuffered webservers ***
detected max file descriptor number: 1024
lock engine: pthread robust mutexes
thunder lock: disabled (you can enable it with --thunder-lock)
uwsgi socket 0 bound to UNIX address /var/www/html/items-rest/socket.sock fd 3
dropping root privileges after socket binding
uWSGI running as root, you can use --uid/--gid/--chroot options
*** WARNING: you are running uWSGI as root !!! (use the --uid flag) ***
Python version: 3.5.2 (default, Nov 23 2017, 16:37:01) [GCC 5.4.0 20160609]
Set PythonHome to /var/www/html/items-rest/venv
Python main interpreter initialized at 0xda8f80
dropping root privileges after plugin initialization
uWSGI running as root, you can use --uid/--gid/--chroot options
*** WARNING: you are running uWSGI as root !!! (use the --uid flag) ***
python threads support enabled
your server socket listen backlog is limited to 100 connections
your mercy for graceful operations on workers is 60 seconds
mapped 1315008 bytes (1284 KB) for 64 cores
*** Operational MODE: preforking+threaded ***
added /var/www/html/items-rest/ to pythonpath.

  • Running on http://127.0.0.1:5000/ (Press CTRL+C to quit)
  • Restarting with stat *** has_emperor mode detected (fd: 6) *** unable to load configuration from uwsgi
2 comments
  • Without more information, it is hard to answer your question. Which tutorial were you following? Can you share the details of your Nginx configuration?

  • @asb this is my Nginx config

    server {
        listen 80 default_server;
        listen [::]:80 default_server;
    
    
        # SSL configuration
        #
        # listen 443 ssl default_server;
        # listen [::]:443 ssl default_server;
        #
        # Note: You should disable gzip for SSL traffic.
        # See: https://bugs.debian.org/773332
        #
        # Read up on ssl_ciphers to ensure a secure configuration.
        # See: https://bugs.debian.org/765782
        #
        # Self signed certs generated by the ssl-cert package
        # Don't use them in a production server!
        #
        # include snippets/snakeoil.conf;
    
        root /var/www/html;
    
            #/usr/share/nginx/html
    
        # Add index.php to the list if you are using PHP
        index index.html index.htm index.php
    
        server_name myserver_ip;
    
        location / {
            # First attempt to serve request as file, then
            # as directory, then fall back to displaying a 404.
            try_files $uri $uri/ =404;
        }
    
        # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
        #
        location ~ \.php$ {
            include snippets/fastcgi-php.conf;
        #
        #   # With php7.0-cgi alone:
        #   fastcgi_pass 127.0.0.1:9000;
        #   # With php7.0-fpm:
            fastcgi_pass unix:/run/php/php7.0-fpm.sock;
        }
    
        # deny access to .htaccess files, if Apache's document root
        # concurs with nginx's one
        #
        #location ~ /\.ht {
        #   deny all;
        #}
    }
    
Be the first one to answer this question.