Followed tutorial for how to setup a host name with Digital Ocean, but still cannot use domain name with Wordpress

July 14, 2015 1.5k views
Apache WordPress Ubuntu

I am setting up a small droplet ($5/mo) with a basic Wordpress installation. I followed the instructions for setting up Wordpress using the LAMP stack from here.

The installation itself seems to be fine, the problem I am having now is that I cannot redirect my domain name to the Wordpress site. The behavior I am seeing is if I go to my droplet's IP address in the browser I am taken to the Wordpress site; however, if I enter my domain name I am taken to the "Is this your domain name? Click here to manage your domain" splash page that my provider uses (domain.com).

I followed the Digital Ocean host name tutorial directions here. To review, this is what I have done so far:

  • I logged into my domain provider and changed the name servers to the x3 Digital Ocean name servers
  • In the DO control panel I went to the DNS tab and added my domain name to my droplet.
    • I have an A record that is @ and then my droplet's IP address (e.g. a.b.c.d)
    • I have a CNAME record that is * and then my desired domain (e.g. example.com)
    • The three name servers are the Digital Ocean name servers.
  • In the Apache /etc/apache2/sites-enabled/000-default.conf file, I have:
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html
        ServerName example.com
        <Directory /var/www/html/>
                AllowOverride All
        </Directory>

(Where example.com is my actual domain name.) I saw in another thread that I should edit the other file that is not 000-default.conf; however, 000-default.conf is the only file I have in that directory.

Port 80 is open - see output of sudo netstat -plunt:

$ sudo netstat -plunt
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      881/sshd
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      969/sendmail: MTA:
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      2604/mysqld
tcp        0      0 127.0.0.1:587           0.0.0.0:*               LISTEN      969/sendmail: MTA:
tcp6       0      0 :::22                   :::*                    LISTEN      881/sshd
tcp6       0      0 :::80                   :::*                    LISTEN      4626/apache2

Please let me know if there's anything else I can provide.

EDIT: I made all these changes ~24 hours ago. I realize that sometimes it takes a little while to propagate the changes, but I believe that it's still well below 24 hours...

3 Answers

Is the default vhost enabled?

apache2 -S
apache2ctl -S

Did you also restart the apache service? And please remove your computers DNS cache or put the domain name here. It could be possible that you are still receiving the cache instead of realtime site.

  • Thank you for the reply!

    It turns out that there was something going on at my domain provider that's been fixed. (I reached out to them yesterday as well.) Yay :)

    I did run the commands that you indicated, though, and for the first I received a syntax error for a config variable?

    $ sudo apache2 -S
    [Wed Jul 15 10:44:42.335249 2015] [core:warn] [pid 14581] AH00111: Config variable ${APACHE_LOCK_DIR} is not defined
    [Wed Jul 15 10:44:42.335538 2015] [core:warn] [pid 14581] AH00111: Config variable ${APACHE_PID_FILE} is not defined
    [Wed Jul 15 10:44:42.335614 2015] [core:warn] [pid 14581] AH00111: Config variable ${APACHE_RUN_USER} is not defined
    [Wed Jul 15 10:44:42.335678 2015] [core:warn] [pid 14581] AH00111: Config variable ${APACHE_RUN_GROUP} is not defined
    [Wed Jul 15 10:44:42.335759 2015] [core:warn] [pid 14581] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
    [Wed Jul 15 10:44:42.373890 2015] [core:warn] [pid 14581] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
    [Wed Jul 15 10:44:42.375388 2015] [core:warn] [pid 14581] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
    [Wed Jul 15 10:44:42.375540 2015] [core:warn] [pid 14581] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
    AH00526: Syntax error on line 74 of /etc/apache2/apache2.conf:
    Invalid Mutex directory in argument file:${APACHE_LOCK_DIR}
    
    $ sudo apache2ctl -S
    AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message
    VirtualHost configuration:
    *:80                   zigzagzafu.com (/etc/apache2/sites-enabled/000-default.conf:1)
    ServerRoot: "/etc/apache2"
    Main DocumentRoot: "/var/www"
    Main ErrorLog: "/var/log/apache2/error.log"
    Mutex watchdog-callback: using_defaults
    Mutex rewrite-map: using_defaults
    Mutex default: dir="/var/lock/apache2" mechanism=fcntl
    Mutex mpm-accept: using_defaults
    PidFile: "/var/run/apache2/apache2.pid"
    Define: DUMP_VHOSTS
    Define: DUMP_RUN_CFG
    User: name="www-data" id=33
    Group: name="www-data" id=33
    

The configuration error is no problem, the command you need to use depends on the OS you are using. The second command gives an output of the vhost, with a result that the default vhost is being used. Good to hear you got it solved now, for any more questions I'll be happy to help you.

Have another answer? Share your knowledge.