Freebsd 10.2 update no mirrors found / invalid signature

November 27, 2015 3.6k views
DigitalOcean System Tools FreeBSD

I've found a number of posts online about this, but the answers are a bit above my skill level. Surely somebody running FreeBSD on Digital Ocean has/had the same problem.

#  sudo freebsd-update fetch
Looking up update.FreeBSD.org mirrors... 5 mirrors found.
Fetching metadata signature for 10.2-RELEASE from update6.freebsd.org... invalid signature.
Fetching metadata signature for 10.2-RELEASE from update5.freebsd.org... invalid signature.
Fetching metadata signature for 10.2-RELEASE from update4.freebsd.org... invalid signature.
Fetching metadata signature for 10.2-RELEASE from update2.freebsd.org... invalid signature.
Fetching metadata signature for 10.2-RELEASE from update3.freebsd.org... invalid signature.
No mirrors remaining, giving up.

Regarding this solution:

Edit /etc/freebsd-update.conf and check the line:
Components src world kernel

and change it to:
Components world kernel

My freebsd-update.conf was already set up like that.

1 comment
  • Hi, never had this problem on FreeBSD. Looking on the official FreeBSD forum it looks like a DNS problem. Can you check the settings of your DNS (/etc/resolv.conf)?

    My /etc/resolv.conf is:

    # Generated by resolvconf
    nameserver 8.8.8.8
    nameserver 8.8.4.4
    

    Those are the Google DNS. They work very well.

2 Answers

Well that is the default. I am already using those addresses.

The solution is related to how the openssl file was altered during the upgrade. Link goes to the solution in the freebsd forum.

[https://forums.freebsd.org/threads/invalid-signature-using-freebsd-update.54234/](http://)

I'm not sure the link is showing up. The solution was to comment out these lines in the openssl.conf file

<<<<<<< current version
=======
# $FreeBSD: releng/10.2/crypto/openssl/apps/openssl.cnf 238405 2012-07-12 19:30:53Z jkim $
>>>>>>> 10.2-RELEASE
Have another answer? Share your knowledge.