FreeBSD Droplet Cannot Connect to the Internet

February 7, 2016 1.7k views
Configuration Management Getting Started DigitalOcean Miscellaneous Linux Basics System Tools FreeBSD

I am running FreeBSD 10.2.
I spun the Droplet, accessed it via ssh, and did the following:

1) cd /usr/ports/ports-mgmt/portmaster/ ; sudo make install clean
2) sudo portmaster -a
3) cd /usr/ports/net/svnup ; sudo make install clean
4) sudo svnup release
5) sudo freebsd-update fetch install
6) sudo reboot

Then, it was not responding to pings, and I could not access it via ssh (additionally, it had no ip address.)

Next, support said I needed to run the following due to a DigitalOcean FreeBSD Provisioning Bug (in Single User Mode):

ln -s /etc/rc.digitalocean.d/[dropletNumber].conf /etc/rc.digitalocean.d/droplet.conf

Now vtnet0 has an ip address, but I have no Internet access, as shown by:

no route to host

At this point support said to ask the community.

Any help would be much appreciated.

Regards, Brandon

2 Answers

Not sure what went wrong with you. This is what I did to set-up my FreeBSD droplet.
Please notice it was done for a 10.1:

sudo portsnap fetch update
cd /usr/ports/ports­mgmt/portmaster
sudo make config­recursive install distclean

Reboot in single user to disable journaling due to a bug in FreeBSD 10.1 with SSD (I suggest you to check if this still apply to 10.2, in fact I'm going to check myself):

sudo nextboot ­-o "-s" -­k kernel
sudo reboot

In single mode:

tunefs -­j disable /

Now we are back in normal mode and we can finish the installation process:

sudo freebsd­-update fetch install
sudo reboot
cd /usr/ports/net/svnup
sudo make config-­recursive install clean
sudo vim /usr/local/etc/svnup.conf   (select the best mirror based on your droplet's location)
sudo svnup release
sudo portmaster ­-L
sudo portmaster ­-a
sudo reboot

Maybe at this point is better to start over with a fresh new droplet.

Anyway, I suggest to use pkg to manage your packages. Building everything may take a very long down time if this is a production machine.



  • Good news, the tunefs part can be skipped as the bug was fixed in 10.2:

  • Sorry, there is a typo (due to copy&paste) in one of the first commands, is:

    sudo make config-­recursive install distclean

    (missing dash in configrecursive)

    • I rebuilt the Droplet and configured it as you described, rebooted, and the problem persists...
      On non-server systems, what would cause this problem? (Aside from router configuration obviously.)

      • I had a similar issue when I executed a system update without proper rebooting (to apply the patches).

        I checked up in my archives and what I did was to edit my /etc/rc.conf file with my interface information:

        ifconfig_vtnet0="inet IP_ADDR netmask 0xffffc000" 

        (of course make sure you place the correct IP_ADDR and ROUTER for your droplet).

        Also, make sure that in /etc/rc.digitalocean.d you have a symlink called droplet.conf pointing to /etc/rc.digitalocean.d/XYZ.conf, where XYZ should be your droplet's id (a number). XYZ.conf is in the same directory.

        To recreate:

        cd /etc/rc.digitalocean.d
        ln -s /etc/rc.digitalocean.d/XYZ.conf droplet.conf

        Then, after a reboot, everything was working fine. I no longer had this issue, and now I'm also running a FreeBSD 10.2.

        If the problem persists, I suggest to look up for similar issues on, and ask there if nothing else helps.

        • Ah, in case you are not sure, you can find your IP addresses in the settings panel of your droplet (on DigitalOcean site).

          Also, check your netmask is the same as the one I placed in the previous command!

        • Huzzah! It worked!

          I didn't think I had to edit the rc.conf seeing as, like you said, the network information was in [dropletNumber].conf

          All problems are solved, thank you greatly.

        • Thanks!
          Recreating droplet.conf link helps to me! :)

Have another answer? Share your knowledge.