Question

Friendly URL's are not working

  • Posted November 6, 2013

I put my website in the www folder, but the friendly url’s are not working anymore. How to solve?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

<b>“I put my website in the www folder…”</b> <br> <br>Is this a new install or did you move your site to the <code>www</code> folder from a different directory?

I changed AllowOveride to All, but when I change <Directory /var/www/> <br> Options Indexes FollowSymLinks MultiViews <br> AllowOverride None <br> Order allow,deny <br> allow from all <br> </Directory> <br> <br>allowoverride all, then the site is not loading anymore. <br> <br>Full file: <br><VirtualHost *:80> <br> ServerAdmin webmaster@localhost <br> <br> DocumentRoot /var/www <br> <Directory /> <br> Options FollowSymLinks <br> AllowOverride All <br> </Directory> <br> <Directory /var/www/> <br> Options Indexes FollowSymLinks MultiViews <br> AllowOverride None <br> Order allow,deny <br> allow from all <br> </Directory> <br> <br> ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/ <br> <Directory “/usr/lib/cgi-bin”> <br> AllowOverride None <br> Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch <br> Order allow,deny <br> Allow from all <br> </Directory> <br> <br> ErrorLog ${APACHE_LOG_DIR}/error.log <br> <br> # Possible values include: debug, info, notice, warn, error, crit, <br> # alert, emerg. <br> LogLevel warn <br> <br> CustomLog ${APACHE_LOG_DIR}/access.log combined <br> <br> Alias /doc/ “/usr/share/doc/” <br> <Directory “/usr/share/doc/”> <br> Options Indexes MultiViews FollowSymLinks <br> AllowOverride None <br> Order deny,allow <br> Deny from all <br> Allow from 127.0.0.0/255.0.0.0 ::1/128 <br> </Directory> <br> <br></VirtualHost> <br>

No, I’m running a opencart website

Are you running a WordPress site?