I am trying to connect with Filezilla to my droplet running on Ubuntu. I have tried in vain to go the SSH keys route but it causes to many connection issues and i want to use a regular FTP client and gain root access,

I have deleted all SSH keys and have reset the root password.
In FTP i try to connect as root@MYIP or serveradmin@MYIP and i use the password sent to me - but it refuses to connect

Putty wont connect even when i tried with the keys as it just aborts with connection error

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
6 answers

@greg36bd0d6b281

To use FTP, you’d need to install and configure an FTP server. SFTP is the method we recommend as it works by default (no additional software is needed), and it works with a password or SSH keys :-).

To setup FileZilla to use SFTP (which works just as FTP does, but it’s secure), you’d setup a profile for the connection using the following configuration:

Port:       22
Host:       Droplet IP
Username:   root
Password:   root password
Protocol:   SFTP

If you’d prefer to use FTP, you can install and configure vsftpd. We do have an older guide that covers the basics, though it’s not 100% all-inclusive and has not been updated since SFTP is the better of the two options.

https://www.digitalocean.com/community/tutorials/how-to-set-up-vsftpd-on-ubuntu-12-04

by Etel Sverdlov
Vsftpd is a fast and secure FTP server. Installing an FTP server can assist you with uploading files to your droplet. This tutorial describes how to install and set up vsftpd on Ubuntu 12.04.

If a password was sent to you, you’re not using keys and unless you’ve gone and installed an FTP server, FTP isn’t going to connect.

Believe it or not you can use Filezilla to connect via SFTP (which is what comes with the droplets), not only is it more secure than FTP, it’s easier as you don’t even have to set it up, just connect!

Just realize that you’ll be sending your droplet’s root password unencrypted over the interent.

I usually have to manually specify port 22 in the quickconnect section of filezilla otherwise it won’t connect. Not sure why.

SFTP is so much slower than FTP that it makes it too long to wait while the project downloads to my local computer.
I want to use FTPS. How do I setup that on Ubuntu droplet?

Absolutely Stunning!!!
It’s workin’ para mi

Submit an Answer