Question

GatsbyJS build with Apps fails because of missing glibc

Hey,

I have a GatsbyJS instance running in App Platform, and the build started failing a few days ago:

[2022-04-21 07:54:55] Project contains yarn.lock, using yarn
[2022-04-21 07:54:55] Installing node_modules using yarn (from yarn.lock)
[2022-04-21 07:54:55] Running yarn install
[2022-04-21 07:54:55] 
[2022-04-21 07:54:55] node: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by node)
[2022-04-21 07:54:55] 
[2022-04-21 07:54:55] unable to invoke layer creator
[2022-04-21 07:54:55] installing node_modules: exit status 1
[2022-04-21 07:54:55] ERROR: failed to build: exit status 1
[2022-04-21 07:54:58] 
[2022-04-21 07:54:58] For documentation on the buildpacks used to build your app, please see:
[2022-04-21 07:54:58]    Node.js: https://do.co/apps-buildpack-node
[2022-04-21 07:54:58] 
[2022-04-21 07:54:58]  ! Build failed (145)

Code wise, nothing changed. The build, when run on local linux or macos, runs just fine. I also tried to use a docker image with App Platform, which runs but in the end fails with an out of memory error. I also tried to downgrade the required node engine in package.json from 17 to 16, still the same result.

Thanks

jan


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer