178.128.144.18
dailyordnance.com

I created the droplet last night set the DNS to ns1/2/3.digitalocean.com.

I set up SSL with Certbot for http and https.

Created A records for dailyordnance.com and www.dailyordnance.com (and *.dailyordnance.com but not sure if this is necessary).

This is a Wordpress install.

I don’t really know what else to do because I’m not very good with networking stuff.

Thank you for any help.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hello, @rottenprimate

Can you please share the Apache/Nginx configuration file with us or check if the document root is correct and pointing to the directory where the WordPress installation is?

Let me know how it goes.

  • Hello, thanks for taking time to respond. My apache2.conf is entirely comments, no settings.

    I think the problem is the files. /var/www is empty except for “html.old”. I never went through with the Wordpress installation because I get the 404.

    I get this on “apache2ctl -S”

    AH00112: Warning: DocumentRoot [/var/www/html] does not exist
    AH00112: Warning: DocumentRoot [/var/www/html] does not exist
    AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
    VirtualHost configuration:
    *:443                  dailyordnance.com (/etc/apache2/sites-enabled/000-default-le-ssl.conf:2)
    *:80                   dailyordnance.com (/etc/apache2/sites-enabled/000-default.conf:4)
    ServerRoot: "/etc/apache2"
    Main DocumentRoot: "/var/www/html"
    Main ErrorLog: "/var/log/apache2/error.log"
    Mutex watchdog-callback: using_defaults
    Mutex rewrite-map: using_defaults
    Mutex ssl-stapling-refresh: using_defaults
    Mutex ssl-stapling: using_defaults
    Mutex ssl-cache: using_defaults
    Mutex default: dir="/var/run/apache2/" mechanism=default
    Mutex mpm-accept: using_defaults
    PidFile: "/var/run/apache2/apache2.pid"
    Define: DUMP_VHOSTS
    Define: DUMP_RUN_CFG
    User: name="www-data" id=33
    Group: name="www-data" id=33
    
    
Submit an Answer