-Everything was going great my website was accessible with IP address of the droplet and the domain name too.

  • Then I have tried to install WordPress on my droplet along with the Django.

-Then I have tried to add the one more domain name for my website(wordpress) on a single droplet and all of sudden my ip address is pointing to that WordPress website Django website was no more associated with my ip address of the droplet.
-Then I have reset my droplet to the factory version.

-Then I have started to host my previous django website from scratch and at the Djangowelcomepage(where we can see that django is activated) and then I have copied the content of my website to the droplet.
-After copying my website content I am getting this (502 bad gateway) error and I am unable to access my website neither with ip address now with domain name.

Can someone please help me?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hello,

I believe that you need to make sure that the gunicorn service is up and running:

systemctl status gunicorn

If it is not running you should start it with:

systemctl start gunicorn

Also after that make sure that your gunicorn.socket socket exists at:

ls -l /home/django/gunicorn.socket

Let me know how it goes!
Regards,
Bobby

Submit an Answer