Question

Getting CSR key for SSL Cert

  • Posted June 6, 2014

Hi

I’m have a problem after generating the code

– I followed instruction on https://www.digitalocean.com/community/articles/how-to-create-a-ssl-certificate-on-apache-for-ubuntu-12-04

– the issue is the when I click on the link, the file gets downloaded instead of opening in a web browser

http://162.243.2.106/findnigeriaproperty/public_html

Please can any one advice what do do?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

thanks, problem solved. I most have done something, daft while generating the csr code.
<pre> apt-get install libapache2-mod-php5 </pre> then <pre> sudo service apache2 restart </pre> And everything is now up and running, thank for your help @alexandre, I also added port :443 – thanks

Thanks guy.

I can’t run - sudo service apache2 restart

anymore…

I get the following error <pre> apache2: Syntax error on line 210 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: cannot open shared object file: No such file or directory Action ‘configtest’ failed. The Apache error log may have more information. …fail! </pre> Grrrrrr…

If you are trying to issue an SSL, please read some CA Documentation, they’ll provide some code references to do so. <br> <br>In other hand, if you generate a SSL and have problems when open in http vs https, then you must check your configuration for VirtualHosts and patch it to open correctly with port 443 (Secure). <br> <br>VirtualHosts, apache conf, other stuffs: <br>https://www.digitalocean.com/community/articles/how-to-set-up-apache-virtual-hosts-on-ubuntu-12-04-lts

Generating a SSL certificate wouldn’t lead to this. This has to do with how Apache is handling php files. First make sure that the php mod for Apache is enabled: <br> <br><pre> <br>sudo a2enmod php5 <br>sudo service apache2 restart <br></pre> <br> <br>If that doesn’t resolve the issue, please paste your Apache configuration so we can help debug the problem.