Question

Getting error on nginx 27496#27496: *2 connect() failed (111: Connection refused) while connecting to upstream, client:

Getting error on nginx 27496#27496: 2 connect() failed (111: Connection refused) while connecting to upstream, client: GET /api/onboarding//*

NGINX config file gives no error.

##
# You should look at the following URL's in order to grasp a solid understanding
# of Nginx configuration files in order to fully unleash the power of Nginx.
# http://wiki.nginx.org/Pitfalls
# http://wiki.nginx.org/QuickStart
# http://wiki.nginx.org/Configuration
#
# Generally, you will want to move this file somewhere, and start with a clean
# file but keep this around for reference. Or just disable in sites-enabled.
#
# Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples.
##

# Default server configuration
#

server {
	listen 80 default_server;
	listen [::]:80 default_server;

	# SSL configuration
	#
	# listen 443 ssl default_server;
	# listen [::]:443 ssl default_server;
	#
	# Note: You should disable gzip for SSL traffic.
	# See: https://bugs.debian.org/773332
	#
	# Read up on ssl_ciphers to ensure a secure configuration.
	# See: https://bugs.debian.org/765782
	#
	# Self signed certs generated by the ssl-cert package
	# Don't use them in a production server!
	#
	# include snippets/snakeoil.conf;

	#root /var/www/html;

	# Add index.php to the list if you are using PHP
	#index index.html index.htm index.nginx-debian.html;

	server_name _;

	#location / {
		# First attempt to serve request as file, then
		# as directory, then fall back to displaying a 404.
	#	try_files $uri $uri/ =404;
	#}

	# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
	#
	#location ~ \.php$ {
	#	include snippets/fastcgi-php.conf;
	#
	#	# With php7.0-cgi alone:
	#	fastcgi_pass 127.0.0.1:9000;
	#	# With php7.0-fpm:
	#	fastcgi_pass unix:/run/php/php7.0-fpm.sock;
	#}

	# deny access to .htaccess files, if Apache's document root
	# concurs with nginx's one
	#
	#location ~ /\.ht {
	#	deny all;
	#}
		location ~ ^/(status|version|parse|train|evaluate|config|models) {
			proxy_pass http://127.0.0.1:5000;
			proxy_read_timeout 600s;
			proxy_set_header Referer "";
		}
		location /login {
			proxy_pass http://127.0.0.1:5005;
		}
		location /data {
                        proxy_pass http://127.0.0.1:7000/data;
                }

		location /api/onboarding/ {
			proxy_pass http://127.0.0.1:7000;
		}

                location /save {
                        proxy_pass http://127.0.0.1:7000/data;
                }

                location /nlu_trainer {
                        root /opt/chanakya/frontend/master/rasa-trainer/build;
                        #try_files $uri /index.html;
                }

                location / {
                        root /opt/chanakya/frontend/master/frontend/dist;
                        try_files $uri /index.html;
                        #index  index.html index.htm;
                }
}

# Virtual Host configuration for example.com
#
# You can move that to a different file under sites-available/ and symlink that
# to sites-enabled/ to enable it.
#
#server {
#	listen 80;
#	listen [::]:80;
#
#	server_name example.com;
#
#	root /var/www/example.com;
#	index index.html;
#
#	location / {
#		try_files $uri $uri/ =404;
#	}
#}

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there,

The Nginx configuration looks correct. The error that you are seeing is due to one of your backend services.

As far as I can see you have a few backend services running on different ports, so you would need to make sure that all of the backend services are up and running.

You can take a look at this video here on how to troubleshoot that specific error:

Regards, Bobby