Getting error while installing phpmyadmin to clean LEMP Stack Ubuntu 14.04

I created a droplet with LEMP app with Ubuntu 14.04.

After that I wanted to install phpmyadmin .

I ran these codes by following this tutorial:

sudo apt-get update
sudo apt-get install phpmyadmin

Then I got a prompt to choose which server I would like to configure; then I push the tab button skip this step.

And then… I got these error and stopped working.

apache2_switch_mpm Switch to prefork
 * Restarting web server apache2                                                AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using Set the 'ServerName' directive globally to suppress this message
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
(98)Address already in use: AH00072: make_sock: could not bind to address
no listening sockets available, shutting down
AH00015: Unable to open logs
Action 'start' failed.
The Apache error log may have more information.

I tried and tried again but nothing happened. Could you please someone help me?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

When you install PHPMyAdmin via apt-get it also installs Apache as a dependency. But Nginx is already running and using port 80 so Apache is unable to start. Ignore that error and make sure Apache doesn’t attempt to start itself during an OS reboot:

sudo update-rc.d -f apache2 remove

Follow the rest of the instructions in that article and PHPMyAdmin should work.