Question

getting errors when installing Postfix, Courier, MySQL And SquirrelMail

  • Posted on January 9, 2014
  • FMCBAsked by FMCB

hi mates,

I get weird error when I try to follow the tutorial in here: http://www.howtoforge.com/virtual-users-and-domains-with-postfix-courier-mysql-and-squirrelmail-debian-wheezy

Basically, I’m trying to setup mail server using these tools : Postfix, Courier, MySQL And SquirrelMail on my Debain 7 web server.

when I follow the first instructions, I get into these errors after entering these commands:

apt-get install postfix postfix-mysql postfix-doc mysql-client mysql-server courier-authdaemon courier-authlib-mysql courier-pop courier-pop-ssl courier-imap courier-imap-ssl libsasl2-2 libsasl2-modules libsasl2-modules-sql sasl2-bin libpam-mysql openssl phpmyadmin apache2 libapache2-mod-php5 php5 php5-mysql libpam-smbpass

This is the error where I can’t continue:

(Reading database … 31002 files and directories currently installed.) Removing dovecot-imapd … […] Starting IMAP/POP3 mail server: dovecotFatal: service(imap) access(/usr/lib/dovecot/imap) failed: No such file or directory failed! invoke-rc.d: initscript dovecot, action “start” failed. dpkg: error processing dovecot-imapd (–remove): subprocess installed post-removal script returned error exit status 1 Removing dovecot-pop3d … […] Starting IMAP/POP3 mail server: dovecotFatal: service(imap) access(/usr/lib/dovecot/imap) failed: No such file or directory failed! invoke-rc.d: initscript dovecot, action “start” failed. dpkg: error processing dovecot-pop3d (–remove): subprocess installed post-removal script returned error exit status 1 Errors were encountered while processing: dovecot-imapd dovecot-pop3d E: Sub-process /usr/bin/dpkg returned an error code (1)

And as I understand that there are some issues with dovecot-pop3d and dovecot-imapd

any idea what to do with this??

Thanks,


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I found the solution. I had to remove the SSL lines from dovcot/dovcot.conf and that did solve the problem. <br> <br>however, new issues showed up such as below: <br> <br>Starting IMAP/POP3 mail server: dovecotFatal: service(pop3) access(/usr/lib/dovecot/pop3) failed: No such file or directory <br> failed! <br>------------------------------- <br> <br>I could solve this one by creating the required files when the issue kept persisting: <br> <br>created: <br> <br>/usr/lib/dovecot/pop3 <br>/usr/lib/dovecot/pop3-login <br>/usr/lib/dovecot/imap <br>/usr/lib/dovecot/imap-login <br> <br>after all things started working. <br> <br>Thanks, <br>

I get the same issue when I try to install dovcot with the following: <br> <br># sudo apt-get install dovecot-lmtpd <br> <br>also I get the same issue when trying to install phpmyadmin <br> <br>any idea how to solve this issue??