verse
By:
verse

Getting The Jetpack server was unable to communicate with your site [HTTP 403]

October 31, 2016 174 views
WordPress Ubuntu 16.04

While trying to connect with Jetpack on my WordPress page getting this error:

Getting The Jetpack server was unable to communicate with your site [HTTP 403]

How to fix this? Thanks!

2 Answers

Do you know did you disabled XML-RPC on your Droplet?
JetPack requires XML-RPC functionality to work.

If you are not sure, you can start from checking do you have dependencies installed on Droplet :

  • sudo apt-get install php-xml php-xmlrpc

It will require you to restart apache (or in nginx in case you use it):

  • sudo systemctl restart apache2

In nginx case :

  • sudo systemctl restart nginx

Try again and see if it solved the problem.

  • I installed this

    sudo apt-get install php7.0-xml php7.0-xmlrpc
    

    but after that installed, still was getting same mistake.

    • This usually fixes the problem. Make sure you restarted apache after this. Did you maybe followed any solution from XML-RPC tutorial? If yes you need to revert changes before using.

      Maybe you can try going to yourdomain.com/xmlrpc.php and see does it shows some error. I'm not sure is this relevant but you can maybe see is it blocked. If everything is setup as needed it needs to show something along XML-RPC server accepts POST requests only.

      WordPress is a popular and powerful CMS (content management system) platform. Its popularity can bring unwanted attention in the form of malicious traffic specially targeted at a WordPress site. There are many instances where a server that has not been protected or optimized could experience issues or errors after receiving a small amount of malicious traffic. This guide will show you how to protect WordPress from XML-RPC attacks on an Ubuntu 14.04 system.

Still having same error... Tried suggested but nothing's changed..

On mydomain.com/xmlrpc.php getting 404 error

Have another answer? Share your knowledge.