Question

Getting "Welcome to Nginx" message after installing letsencrypt certbot on ubuntu 16.04

After going through the tutorial on how to set up django with nginx on ubuntu 16.04 my website was running perfectly fine but after i tried adding the letsencrypt certbot, my domain is working with https but i am getting “Welcome to nginx” message.

any suggestion

https://www.digitalocean.com/community/tutorials/how-to-set-up-django-with-postgres-nginx-and-gunicorn-on-ubuntu-16-04

https://www.digitalocean.com/community/tutorials/how-to-set-up-django-with-postgres-nginx-and-gunicorn-on-ubuntu-16-04

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

try this: it worked for me after installing letsencrypt on centos 6 linux

server { listen 80 default_server; server_name {domain-name} ; return 301 https://$server_name$request_uri; }

server { listen 443 ssl http2; server_name {domain-name} ;

ssl on; ssl_certificate /etc/letsencrypt/live/{domain-name}/fullchain.pem; ssl_certificate_key /etc/letsencrypt/live/{domain-name}/privkey.pem; ssl_session_timeout 5m; ssl_protocols TLSv1 TLSv1.1 TLSv1.2; ssl_ciphers ‘EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH’; ssl_prefer_server_ciphers on; ssl_session_cache shared:SSL:10m; location / { proxy_pass http://localhost:8080; proxy_http_version 1.1; proxy_set_header Upgrade $http_upgrade; proxy_set_header Connection ‘upgrade’; proxy_set_header Host $host; proxy_cache_bypass $http_upgrade; } location /.well-known/acme-challenge/ { root /var/www/domainame; }

}

The last line acme challenge one is vital for generating your website page. .

nope, i just rebuild the droplet with same configuration (same droplet size, location)…

i never deleted the droplet by myself, but digitalocean does it from there side and gave me a new droplet with same configuration.