Ghost 0.4 Install Problems

  • Posted January 15, 2014

I decided to manually install Ghost 0.4. My problem is I get these errors when I run npm install --production. I tried to proceed with the installation but now ghost will not start and my site returns 502 errors. Any idea where the problem is? :)

sqlite3@2.1.19 install /var/www/ es/sqlite3 node build.js

[sqlite3]: Checking for 3-v2.1.a-node-v11-linux-x64.tar.gz [sqlite3]: Error: ENOENT, open ‘/home/tan/tmp/node-sqlite3-Release/node_sqlite3- v2.1.a-node-v11-linux-x64.tar.gz’ npm ERR! sqlite3@2.1.19 install: node build.js npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the sqlite3@2.1.19 install script. npm ERR! This is most likely a problem with the sqlite3 package, npm ERR! not with npm itself. npm ERR! Tell the author that this fails on your system: npm ERR! node build.js npm ERR! You can get their info via: npm ERR! npm owner ls sqlite3 npm ERR! There is likely additional logging output above.

npm ERR! System Linux 3.8.0-29-generic npm ERR! command “/usr/bin/node” “/usr/bin/npm” “install” “–production” npm ERR! cwd /var/www/ npm ERR! node -v v0.10.24 npm ERR! npm -v 1.3.21 npm ERR! code ELIFECYCLE npm ERR! npm ERR! Additional logging details can be found in: npm ERR! /var/www/


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I symlinked nodejs to node to get around the naming issue. This is also what Joyent recommends trying. <br> <br>% ln -s /usr/bin/nodejs /usr/bin/node <br> <br>Fixed my issues.

Same problem and none solution above works :-(

Seems to work for me when I rebuild the sqlite3 package from source. <br> <br>sudo npm install sqlite3 --build-from-source <br> <br>Then just run as before: <br> <br>sudo npm install --production <br>sudo npm start

Ran into an issue starting afterwards. Go into package.json again and change this under scripts “start”: "node index"to this “start”: “nodejs index”. They were still using the legacy binary name for nodejs and that caused issue…

I had to rollback the version of sqlite3 from 2.2.19 to 2.2.15, didn’t work with the newer 2.2.0 version that was just released… Lame. Regardless though, in the package.json file change this line <br>“sqlite3”: “2.1.19” <br>to this <br>“sqlite3”: “2.1.15”

I decided to reinstall everything using the DO ghost app… The original droplet was a manual install. Don’t know if DO uses a different setup to make ghost run.

Seems like a problem with the sqlite3 package itself. The downloaded archive could be corrupted, try clearing .npm’s cache: <br><pre>npm cache clean</pre>