Question

Ghost can't send mail using Gmail (Google Apps)

Posted March 2, 2015 10.8k views

I verified my domain, I added MX records, the user and password is correct.

mail: {
            service: 'Gmail',
            transport: 'SMTP',
            options: {
                host: 'smtp.gmail.com',
                port: 465,
                secureConnection: true,
                auth: {
                    user: '*******@my-domain.com',
                    password: '******'
                }
            }
        }

And I keep getting this error:
“AuthError: Invalid login - 535-5.7.8 Username and Password not accepted. Learn more at 535 5.7.8 http://support.google.com/mail/bin/answer.py?answer=14257

What else should I do?

1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
5 answers

Are you using your domain with Google Apps or is it Google Mail (@gmail.com).

If it is @gmail.com address you will need to make the username the full email address.

If that doesn’t work please post full configuration files (remove any passwords of course!) as it makes it harder to troubleshoot issues like this. Thanks!

Forget gmail, that’s cheap solution, cheap not as not expensive but as tacky solution. Try mandrillapp.com

Same error here, but i’m using @gmail.com… any solution? Thanks!

Any solution?? Having the same error! I’m using @gmail.com

2020 - Same problem.
No love. Tried l"allow apps with lower security"
Tried App passwords in gmail.
Ghost just does not seem to play nice with gmail.

  • check your mail config, should be something like this:

    "mail": {
        "transport": "SMTP",
        "options": {
          "service": "Gmail",
          "auth": {
            "user": "example@gmail.com",
            "pass": "myexamplepassword"
          }
        }
    }
    
    

    remove all extra properties, and note it is ‘pass’, not password

Submit an Answer