Ghost droplet doesn't resolve DNS

February 24, 2015 521 views

I fired up a Ghost (Ubuntu 14.04) droplet recently, and tried to switch my domain over to it. It was previously on Amazon Route 53, but I deleted that hosted zone, then switched the nameservers over to these guys at the registrat (iwantmyname):

I also changed the nginx ghost file and the config.js file:

server {
    listen 80 default_server;
    listen [::]:80 default_server ipv6only=on;

    server_name ;

    root /usr/share/nginx/html;
    index index.html index.htm;

    client_max_body_size 10G;

    location / {
        proxy_pass http://localhost:2368;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header Host $http_host;
        proxy_set_header X-Forwarded-Proto $scheme;
        proxy_buffering off;

And then the config.js file:

var path = require('path'),

config = {
    // ### Production
    // When running Ghost in the wild, use the production environment
    // Configure your URL and mail settings here
    production: {
        url: '',
        mail: {
          transport: 'SMTP',
           host: '',
        options: {
                service: 'Mandrill',
                auth: {
            user: 'email',
            pass: 'key',

No luck though. When I use host it shows this:

Host not found: 2(SERVFAIL)

And when I check the ip address it shows this:

Host not found: 3(NXDOMAIN)

Any ideas?

1 Answer

It looks like you may have just been encountering delays while your DNS changes propagated. appears to resolve properly to a Ghost blog.

Have another answer? Share your knowledge.