Question

Ghost Image - nginx Redirection to Ghost

I’ve installed the ghost image and I’m trying to figure out where the redirect to Ghost is?

I’ve checked the nginx config and the root is here:

/usr/share/nginx/www

But can’t see anything that redirects to Ghost?

Also if I put a html or php file in the document root it’s not accessible?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Can you pastebin the whole file?

Hello, <br> <br>I’m having a similar problem, with nginx redirecting everything to Ghost. I have ghost running under the subdirectory /blog via nginx, following this guide http://www.allaboutghost.com/how-to-install-ghost-in-a-subdirectory, but now it returns Ghosts 404 page for the root folder. The droplet is running the Ghost application and have only been edited in the ghost config.js to fit /blog and in the default file under sites-available, according to <br> <br><code> <br> <br>location ^~ /blog { <br> proxy_set_header X-Real-IP $remote_addr; <br> proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; <br> proxy_set_header Host $http_host; <br> proxy_set_header X-NginX-Proxy true; <br> <br> proxy_pass http://127.0.0.1:2368; <br> proxy_redirect off; <br> } <br></code> <br> <br> <br>Has anyone any suggestion? <br> <br> <br>

Nginx doesn’t use .htaccess files. It just proxies all requests to Ghost (take a look at the files in <code>/etc/nginx/sites-enabled</code>).