Hi everyone!

I am new to DigitalOcean, and I am trying to install Ghost through a 1 click droplet.
My domain is set up with DigitalOcean and points to the correct Nameservers as well as the right IP address, however I always receive the error below when installing.
I have tried this process a few times, having destroyed and made a new droplet each time.

Here is the updated error:

One or more errors occurred.

1) ProcessError

Message: Command failed: /bin/sh -c sudo -S -p '#node-sudo-passwd#' /etc/letsencrypt/acme.sh --issue --home /etc/letsencrypt --domain saimkhan.co.uk --webroot /var/www/ghost/system/nginx-root --reloadcmd "nginx -s reload" --accountemail saim.khan2312@gmail.com
[Sat Aug 22 21:12:21 UTC 2020] saimkhan.co.uk:Verify error:No valid IP addresses found for saimkhan.co.uk
[Sat Aug 22 21:12:21 UTC 2020] Please add '--debug' or '--log' to check more details.
[Sat Aug 22 21:12:21 UTC 2020] See: https://github.com/acmesh-official/acme.sh/wiki/How-to-debug-acme.sh

[Sat Aug 22 21:12:13 UTC 2020] Create account key ok.
[Sat Aug 22 21:12:13 UTC 2020] Registering account
[Sat Aug 22 21:12:15 UTC 2020] Registered
[Sat Aug 22 21:12:15 UTC 2020] ACCOUNT_THUMBPRINT='pR2bpodwfCvJzsdSe4rDa4Da7rZ5gjeHTN32yExU0ao'
[Sat Aug 22 21:12:15 UTC 2020] Creating domain key
[Sat Aug 22 21:12:15 UTC 2020] The domain key is here: /etc/letsencrypt/saimkhan.co.uk/saimkhan.co.uk.key
[Sat Aug 22 21:12:15 UTC 2020] Single domain='saimkhan.co.uk'
[Sat Aug 22 21:12:15 UTC 2020] Getting domain auth token for each domain
[Sat Aug 22 21:12:17 UTC 2020] Getting webroot for domain='saimkhan.co.uk'
[Sat Aug 22 21:12:17 UTC 2020] Verifying: saimkhan.co.uk

Exit code: 1


Debug Information:
OS: Ubuntu, v18.04.4 LTS
Node Version: v12.18.0
Ghost Version: 3.30.2
Ghost-CLI Version: 1.14.1
Environment: production
Command: 'ghost install --auto --db=mysql --dbhost=localhost --dbname=ghost_production --dbuser=ghost --dbpass=2fa4a28cafa0304abee1ded4a903b2db4e46cead06d69bd3 --dir=/var/www/ghost --start'

Additional log info available in: /home/ghost-mgr/.ghost/logs/ghost-cli-debug-2020-08-22T21_12_44_673Z.log

Try running ghost doctor to check your system for known issues.

You can always refer to https://ghost.org/docs/api/ghost-cli/ for troubleshooting.

------------------------------------------------------------------------------

For any further commands, please switch to the ghost-mgr user to manage Ghost.

sudo -i -u ghost-mgr

------------------------------------------------------------------------------

Please let me know if I am doing something wrong, and if so, how to fix it!

Thanks again :)

edited by MattIPv4

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi there @khansaim506,

At the moment when I try to visit your domain name, I can see that it loads as expected.

The error that you are seeing means that either your DNS A record for your domain name was not pointed to the Droplet’s IP address or you made the DNS change too soon and there was still some DNS caching.

Regards,
Bobby

Submit an Answer