Question

ghost setup error Parameter "url" must be a string, not undefined

Posted May 31, 2019 1.1k views
GhostUbuntu 18.04

While installing ghost from digitalocean marketplace i get the following error.
The setup doesn’t ask me for url.

Ghost will prompt you for two details:

  1. Your domain
    • Add an A Record -> 46.101.110.243 & ensure the DNS has fully propagated
    • Or alternatively enter http://46.101.110.243
  2. Your email address (only used for SSL)

Press enter when you’re ready to get started!

✔ Checking system Node.js version
✔ Checking logged in user
✔ Checking current folder permissions
✔ Checking operating system compatibility
✔ Checking for a MySQL installation
✔ Checking memory availability
✔ Checking for latest Ghost version
✔ Setting up install directory
✔ Downloading and installing Ghost v2.23.1
✔ Finishing install process
✖ Configuring Ghost
✖ Setting up instance

  • sudo useradd –system –user-group ghost
  • sudo chown -R ghost:ghost /var/www/ghost/content ✔ Setting up “ghost” system user ℹ Setting up “ghost” mysql user [skipped] ✖ Setting up Nginx Nginx setup task failed, skipping SSL setup ℹ Setting up SSL [skipped] One or more errors occurred.

1) undefined

TypeError: Parameter “url” must be a string, not undefined

2) undefined

TypeError: Parameter “url” must be a string, not undefined

3) undefined

TypeError: Parameter “url” must be a string, not undefined
Debug Information:
OS: Ubuntu, v18.04
Node Version: v8.10.0
Ghost-CLI Version: 1.10.1
Environment: production
Command: ‘ghost install –auto –db=mysql –dbhost=localhost –dbname=ghost_production –dbuser=ghost –dbpass=43sddsdffsd4484c24aa41f405c7f1f64ef3df340c9834 –dir=/var/www/ghost –start’

Try running ghost doctor to check your system for known issues.

Submit an answer

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!