Question

git push dokku master requires password

I’ve got Ubuntu 14.04 droplet. I try to push the app to dokku repo, but it requests password, which I don’t have. What I do: ssh root@dmitrysmirnov.eu git clone git@github.com:my_username/my_repo.git git remote add dokku dokku@my_hostname:my_app

And it requires: dokku@dmitrysmirnov.eu’s password:

I’ve seen people suggesting doing following: cat ~/.ssh/id_rsa.pub | ssh root@my_hostname “sudo sshcommand acl-add dokku [description]” - I tried running it from my computer (not on root@my_hostname) - but it didn’t help.

What could be the problem? Any ideas on how to troubleshoot?

Subscribe
Share

Try running that command on the dokku host, and not localy:

cat ~/.ssh/idrsa.pub | sudo sshcommand acl-add dokku admin - I tried running it from my computer (not on root@my_hostname) - but it didn't help.

Note that the installation process for dokku should provide you with a web ui at that host.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I followed the command line

cat ~/.sshauthorized_keys/id_do_rsa.pub | ssh root@{droplet_ip} "sudo sshcommand acl-add dokku admin"

When I do , git push dokku master Password is still asked.

dokku@{droplet_ip}'s password: 

So what did you exactly do ?

Solved myself. Didn’t understand that git push dokku master has to be done from local, not from server.