Gitlab site says to configure Gitlab-CE installation, what can I do get back into my site?

Posted February 13, 2018 4.9k views
GitUbuntu 16.04


I have a droplet set up for a while with Gitlab-CE from a one-click install. I believe Gitlab was at 9.2.5 when I created the droplet.

I have tried to keep the droplet up to date, but today I noticed that the site was not working. There was an error about unsecure connection. I have had this issue before, and it was easily fixed by updating my droplet. I went and did that but still could not get into my site.

I checked the Let’s Encrypt certificate to see if it needed to be renewed with sudo certbot renew --dry-run but that showed these errors:

Attempting to renew cert ( from /etc/letsencrypt/renewal/ produced an unexpected error: Failed authorization procedure. (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from "<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<title>404 Not Found</title>
<h1>Not Found</h1>
<p". Skipping.
All renewal attempts failed. The following certs could not be renewed:
  /etc/letsencrypt/live/ (failure)

** DRY RUN: simulating 'certbot renew' close to cert expiry
**          (The test certificates below have not been saved.)

All renewal attempts failed. The following certs could not be renewed:
  /etc/letsencrypt/live/ (failure)
** DRY RUN: simulating 'certbot renew' close to cert expiry
**          (The test certificates above have not been saved.)
1 renew failure(s), 0 parse failure(s)

 - The following errors were reported by the server:

   Type:   unauthorized
   Detail: Invalid response from
   <title>404 Not Found</title>
   <h1>Not Found</h1>

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address.

I have made sure that the A record for did not get removed somehow and it is still there. I even removed it and created it again just to be safe.

Can someone please help me get back into my Gitlab site? I have important code saved and would prefer not to have to start the server over.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
3 answers

Take a look at - add this to the server block

location ^~ /.well-known/acme-challenge/ {
  default_type "type/plain";
  root /tmp/letsencrypt;

issue this command
mkdir /tmp/letsencrypt

Restart Gitlab and then try and renew the SSL

.. or you can reconfigure gitlab to not use SSL

  • Hi @jasonjpeters

    Thank you for replying!

    I tried that, but it did not work. I still get the unauthorized error for Let’s Encrypt when trying to renew it.

    Here is my gitlab.rb file:

     external_url ""
     gitlab_rails['gitlab_email_from'] = ""
     gitlab_rails['gitlab_support_email'] = ""
     #gitlab_rails['smtp_enable'] = true
     #gitlab_rails['smtp_address'] = ""
     #gitlab_rails['smtp_port'] = 456
     #gitlab_rails['smtp_user_name'] = ""
     #gitlab_rails['smtp_password'] = ""
     #gitlab_rails['smtp_domain'] = ""
     #gitlab_rails['smtp_authentication'] = "login"
     #gitlab_rails['smtp_enable_starttls_auto'] = true
     #gitlab_rails['smtp_openssl_verify_mode'] = 'peer'
     nginx['redirect_http_to_https'] = true
     nginx['ssl_certificate'] = "/etc/letsencrypt/live/"
     nginx['ssl_certificate_key'] = "/etc/letsencrypt/live/"
     #nginx['custom_gitlab_server_config'] = "location ^~ /.well-known { root /var/www/letsencrypt; }"
     nginx['custom_gitlab_server_config'] = "location ^~ /.well-known/acme-challenge/ { default_type 'type/plain'; root /tmp/letsencrypt; }"
    #external_url ""

    Does everything look right?

    I would rather not reconfigure gitlab to not use ssl.

    • I suspect that certbot is not able to connect properly to verify and that is why you are getting that error.

      Cerrtbot itself connect on port 80 however your Gitlab settings are redirecting all traffic to 443 with this line:

       nginx['redirect_http_to_https'] = true

      You can remove this line:

      nginx['custom_gitlab_server_config'] = "location ^~ /.well-known/acme-challenge/ { default_type 'type/plain'; root /tmp/letsencrypt; }"

      and update this line:

       #nginx['custom_gitlab_server_config'] = "location ^~ /.well-known { root /var/www/letsencrypt; }"


      nginx['custom_gitlab_server_config'] = "location ^~ /.well-known { root /var/www/letsencrypt; allow all; }"

      That’s just a clean up as the lines were pretty much the same. However that does not solve the the SSL renewal issue.

      Here is an article with how to setup LetsEncrypt with GitLab.

      Double check your settings with that.

      If you have Port 80 disabled/blocked in your firewall, you would need to have that open.

      by Justin Ellingwood
      GitLab, specifically GitLab CE (Community Edition), is an open source application primarily used to host Git repositories, with additional development-related features like issue tracking. The GitLab project makes it relatively straight forward to set up a GitLab instance on...
      • Hello again,

        Sorry for the late reply. I have changed the settings in gitlab.rb as suggested and went through the linked article to make sure all the settings are correct.

        Even after all that, I still get an error when trying to renew the certificate for my site. I have port 80 open on UFW.

        I would hate to have to start over, but is that my best option at this point or is there something else I can try?

That is quite alright.

If you would like to give it a shot. (backup your Gitlab configuration file)

This is how I run my Gitlab installation - non-bundled NGINX webserver

You will need to install NGINX

wget -O - | sudo apt-key add -

echo "deb xenial nginx
deb-src xenial nginx" > /etc/apt/sources.list.d/nginx.list

apt-get -y update

apt-get -y install nginx

this will install NGINX Mainline

My NGINX configuration looks like this - replace YOURSERVERFQN with your server domain

upstream gitlab-workhorse {
  server unix:/var/opt/gitlab/gitlab-workhorse/socket fail_timeout=0;

server {


  server_name YOUR_SERVER_FQN;
  server_tokens off;

  location / {
    return 301 https://$http_host$request_uri;    

  # Letsencrypt Verification
  location ~ /.well-known {
    root /usr/share/nginx/html;
    allow all;

  access_log  /var/log/nginx/gitlab_access.log;
  error_log   /var/log/nginx/gitlab_error.log;


server {

  listen ssl;

  server_name YOUR_SERVER_FQDN;
  server_tokens off;

  root /opt/gitlab/embedded/service/gitlab-rails/public; 

  ssl on;
  ssl_certificate /etc/letsencrypt/live/git.YOUR_SERVER_FQN/fullchain.pem;
  ssl_certificate_key /etc/letsencrypt/live/git.YOUR_SERVER_FQN/privkey.pem;

  ssl_protocols TLSv1 TLSv1.1 TLSv1.2;

  ssl_prefer_server_ciphers on;
  ssl_ecdh_curve secp384r1;

  ssl_session_cache shared:SSL:10m;
  ssl_session_tickets off;

  ssl_stapling on;
  ssl_stapling_verify on;

  resolver valid=300s;
  resolver_timeout 5s;

  add_header Strict-Transport-Security "max-age=63072000; includeSubdomains";
  add_header X-Frame-Options DENY;
  add_header X-Content-Type-Options nosniff;

  ssl_dhparam /etc/ssl/certs/dhparam.pem;  

  access_log  /var/log/nginx/gitlab_access.log;
  error_log   /var/log/nginx/gitlab_error.log;

  location / {
    client_max_body_size 0;
    gzip off;

    proxy_read_timeout      300;
    proxy_connect_timeout   300;
    proxy_redirect          off;

    proxy_http_version 1.1;

    proxy_set_header    Host                $http_host;
    proxy_set_header    X-Real-IP           $remote_addr;
    proxy_set_header    X-Forwarded-Ssl     on;
    proxy_set_header    X-Forwarded-For     $proxy_add_x_forwarded_for;
    proxy_set_header    X-Forwarded-Proto   $scheme;
    proxy_pass http://gitlab-workhorse;


I have the same problem, But still can’t fix it.
Are there any idea.
Please help us. :(