Question

Gitlab with Gmail

  • Posted on June 5, 2014
  • troyhiAsked by troyhi

noob question here, I am trying to give my new droplet with Gitlab installed the ability to send mail / messages with a gmail account. I have googled for this and come back with good instructions like these

http://elijahpaul.co.uk/using-an-smtp-server-with-gitlab/

But he is referencing paths to files that I can’t seem to find such as

config/environments/production.rb

I am not really sure where i should be looking, I am somewhat beating my head on the wall. can anyone give me some pointers so that I can learn more.

System info

Distributor ID: Ubuntu Description: Ubuntu 14.04 LTS Release: 14.04 Codename: trusty

Gitlab 6.4.2 ?

Thanks !


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This comment has been deleted

The newer GitLab images use the omnibus installer. You can edit settings in: <code>/etc/gitlab/gitlab.rb </code> <br> <br>You probably want to add something like: <br> <br><pre> <br>gitlab_rails[‘smtp_enable’] = true <br>gitlab_rails[‘smtp_address’] = ‘smtp.gmail.com’ <br>gitlab_rails[‘smtp_port’] = 587 <br>gitlab_rails[‘smtp_user_name’] = ‘account@gmail.com’ <br>gitlab_rails[‘smtp_password’] = ‘password’ <br>gitlab_rails[‘smtp_domain’] = ‘gmail.com’ <br>gitlab_rails[‘smtp_authentication’] = :plain <br>gitlab_rails[‘smtp_enable_starttls_auto’] = true <br></pre> <br> <br>For the changes to take effect you need to run: <br> <br><pre> <br>sudo gitlab-ctl reconfigure <br></pre>

Try running the following command as root: <pre>find / -name production.rb 2>/dev/null</pre>