Question

Google can´t find MX records for DNS

I’m trying to set up gmail for my domain.

I added the google settings to my MX Records as seen below

ASPMX.L.GOOGLE.COM. ALT1.ASPMX.L.GOOGLE.COM. ALT2.ASPMX.L.GOOGLE.COM. ALT3.ASPMX.L.GOOGLE.COM. ALT4.ASPMX.L.GOOGLE.COM.

but Google don´t seem to find the Records I have already waited 48hrs and the result was that I didn´t have any MX records. I have double checked the spelling and it all adds up.

The domain is from Godaddy but I’ve directed the name servers to Digital Ocean.

I really don´t know why this isn’t working and I don´t want to be without my email for another 48hrs.

here is the Zonefile

$ORIGIN www.mydomain.com. $TTL 1800 www.mydomain.com. IN SOA ns1.digitalocean.com. hostmaster.www.mydomain.com. www.mydomain.com. 1800 IN NS ns1.digitalocean.com. www.mydomain.com. 1800 IN NS ns2.digitalocean.com. www.mydomain.com. 1800 IN NS ns3.digitalocean.com. www.mydomain.com. 1800 IN A 138.68.150.155 www.www.mydomain.com. 1800 IN CNAME www.mydomain.com. www.mydomain.com. 1800 IN MX 1 aspmx.l.google.com. www.mydomain.com. 1800 IN MX 5 alt1.aspmx.l.google.com. www.mydomain.com. 1800 IN MX 5 alt2.aspmx.l.google.com. www.mydomain.com. 1800 IN MX 10 alt3.aspmx.l.google.com. www.mydomain.com. 1800 IN MX 10 alt4.aspmx.l.google.com.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Adding this answer if anyone stumbled upon this question while trying to resolve the similar issues i had.

I had a similar issue, it seems like Add Gmail MX records creates wrong records. replacing ASPMX.L.GOOGLE.COM. with gmr-smtp-in.l.google.com. worked for me.

This comment has been deleted

Your mx records should be for mydomain.com not www.mydomain.com.