Googlebot can't access your site

December 16, 2012 5.5k views
Hi, I've got an email from google stating that it wasn't able to access my website: --- Over the last 24 hours, Googlebot encountered 1 errors while attempting to retrieve DNS information for your site. The overall error rate for DNS queries for your site is 100.0%. You can see more details about these errors in Webmaster Tools. --- I've looked through my DNS configuration in digitalocean dashboard, and all seems fine. Is there something that i'm missing?
5 Answers
Googlebot fetches DNS in much the same way as a users Browser would.

If you can access your site in your browser, i would assume that this error will simply go away.

You may wish to resubmit, reindex, or otherwise speed up the re-crawling of your site.

You may also, under "Health", select "Fetch as Google".

Run this on the page that this error effects (your home page if you are unsure) and if it returns as "Success", you can ignore this error, as it will resolve itself within a few days.

My websites are working fine,I am using Ubuntu 12.04 ufw and some specific ports are allowed.ICMP is also blocked.Issue is when I enable firewall Googlebot unable to access my sites but when I disable UFW ,Googlebot can access my sites.
Thanks in advance.

  • Try enabling ICMP, Googlebot probably uses that. Edit /etc/ufw/before.rules and uncomment -A ufw-before-input -p icmp --icmp-type echo-request -j ACCEPT and restart ufw.

Thanks Kamal ,I will try this ,Is there no option to allow googlebot with ICMP blocked?

  • It's a bit hard to do that because Google doesn't publish a list of IPs that it uses for Googlebot so you'll need to allow everyone to send ICMP packets (ICMP packets are the packets that sent when you run ping your-ip) which doesn't really affect your droplet's security.

Hi Kamal,
Here is my UFW configuration.

ok icmp codes

-A ufw-before-input -p icmp --icmp-type destination-unreachable -j DROP
-A ufw-before-input -p icmp --icmp-type source-quench -j DROP
-A ufw-before-input -p icmp --icmp-type time-exceeded -j DROP
-A ufw-before-input -p icmp --icmp-type parameter-problem -j DROP
-A ufw-before-input -p icmp --icmp-type echo-request -j ACCEPT
As per your suggetion ,I changed DROP to ACCEPT in last line.
Is it ok or I have to ACCEPT all ICMP?

Have another answer? Share your knowledge.