Gunicorn setup / error for django application

  • Posted December 31, 2014

I just started using digitalocean, and wanted to host a Django 1.7 application on a server. I copied over my django project to the server, and installed the few packages I needed to run it. I tested and made sure that I could run the site using the the built in django development server. After doing that however, I went to setup gunicorn as is shown in this tutorial: After changing the filename and path to match my django project I typed “service gunicorn restart” only to have the shell say:

stop: Unknown job: gunicorn start: Unknown job: gunicorn

I’ve never used gunicorn before and have no idea what is going wrong. I was hoping I could get some help finishing my setup and publishing the site.



Got the same error. Tried to do the init-checkconf, it says the syntax is ok… So I do not know what is going on.

The Django One-Click application does use Django 1.6, but that shouldn’t cause this error. Does the Upstart script exist on the server? It should be located at /etc/init/gunicorn.conf

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I’m having the same error. Gunicorn not found, eventhough I am able to run it manually from virtualenvironment.

It still doesn’t work when the syntax is ok.


init-checkconf /etc/init/gunicorn.conf

to check if your gunicorn.conf fie is alright - if the syntax is wrong, that command will say so, which could be the problem.

DO is using Django 1.6.