Question

Haraka installation stuck at http fetch GET 200

I was trying to install Haraka in my digital ocean droplet that runs with Ubuntu 20.04.4 LTS. I tried installating multiple times but stuck at same point (and installation gets killed after some time) that is

( ##################) ⠏ reify:moment: http fetch GET 200 https://registry.npmjs.org/moment/-/moment-2.29.4.tgz 7284ms (cache miss)

I executed npm install -g Haraka as shown here: http://haraka.github.io/ . This command worked on my Ubuntu server in my virtual box with same version.

I tried doing apt update && apt upgrade , I rebooted it, done apt clean, apt remove, apt autoclean, apt autoremove and even cleaned npm cahce using npm cache clear --force but still same problem. Kindly, provide a solution.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there,

What version of npm are you running on your local Ubuntu virtual machine?

What I could suggest is trying to upgrade your npm version on your Droplet so that it matches the on your local virtual machine, eg:

npm install -g npm@8.5.1

Make sure to change the 8.5.1 part so that it matches the version that you are using locally.

Let me know how it goes!

Best,

Bobby