Has anybody got a remote desktop working

March 28, 2013 13k views
I'm trying to get xrdp to work with Bitvise, however it is saying it can't start the remote session. From Ubuntu 12.04 x32 as root >apt-get install tightvncserver >apt-get install xrdp Then from Bitvise that already has a SSH tunnel, attempt "New Remote Desktop" which is using a windows XRDP - connects but then comes back with can't start session as .Xsession not present. From I have created .Xsession & restarted, with the following gnome-session --session=ubuntu-2d but still no luck. Anybody else managed to find a reasonable way of going from Win (in my case XP) to Ubuntu on a droplet
1 comment
5 Answers
SSH is remote desktop, files can transferred through SFTP, There are really not much difference from using graphical approach like remote desktop in windows. Command line interface can seem scary at first, but after playing with it for a while, you will become familiar with it just like what happen to us with graphical user interface.

I also installed a VNC server in to make things easier as I was new to linux vps and SSH. But graphical VNC reduced the droplet's performance so bad I reverted back to the CLI. After reading tutorials for a while, I actually find CLI may actually be quicker. The amount of technical details may be discouraging, but I have actually learnt quite a lot from it and helped me appreciated the value of open source lol. It is amazing to discover the incredible amounts of useful resources that are available for free out there, it really made me appreciated the individual efforts and hard works to enable us to utilise those resources much more resourcefully and economically.

Prices of GUI servers still give me nightmare.

I was able to get the xrdp to load properly in linuxmint 17/Ubuntu 14.04 LTS.

Bellow steps I followed to get xrdp running.

Process to install XRDP using XFCE
The following is an installation in Linuxmint 17 / Ubuntu 14.04 LTS

update your packages

1) sudo apt-get update

update you packages

2) sudo apt-get upgrade

Install remote remote vnc server, must do this before installing xrdp. if you have installed xrdp prior to tightvncserver Remove xrdp by typing sudo apt-get remove xrdp

3) sudo apt-get install tightvncserver

Install Remote Desktop Protocol

4) sudo apt-get install xrdp

install XFCE for Remote Desktop Invironment

5) sudo apt-get install xubuntu-desktop

Setup xsession to use XFCE

6) echo "xfce4-session" > ~/.xsession

Restart xrdp

7) sudo service xrdp restart

For Ubuntu 12 you might want to read the instructions in the link below:

We are mapping the VNC to a websocket and then exporting that out for the webconsole which is most likely why the standard remote desktop isn't working for you.
This worked for me:
by Bulat Khamitov
VNC will allow you to connect to your server remotely, as well as be able to use your keyboard, mouse, and monitor to interface with that server. Get it setup on your Ubuntu 12 cloud server.
Have another answer? Share your knowledge.