Has Anyone Used Easy Engine on Ubuntu 14.04 and had a successful install of wordpress?

June 21, 2015 3.2k views
Applications LEMP WordPress

Hi guys, I was curious to know if anyone using wordpress has ran easy engine to put wordpress on ubuntu 14.04.

The reason I tried it, was all of my install methods failed (including this but not as badly s the others!).

I am not giving up, and was wondering if anyone had any advice on finishing the process. I know that nginx is properly configured, and mysql, php, memcache, hhvm, and that my droplet is functional, but adding wordpress seems to put me in a jam.

Any input would be great.

FYI, I have attempted compiling by spinning up a fresh ubuntu 14.04, 12.04 32 bit and 64 bit droplet, centos 6 and 7, and every imaginable linux distro available. I love the flexibility here, but I can’t seem to nail it down.

At first I though maybe it was my virtual hosts config, as ubuntu, centos, and all linux distros use /html instead of the usual www/ so I used the mkdir command to manually create a directory structure that matches the days of old.

I also tried using the mkdir directive to add public_html to the relevant directories, I created vhosts for each one of these directories each time on each os and attempted the install of wordpress into the pertinent directories. each time i destroyed the droplet, and rebuilt the stack.

Currently i have ubuntu 14.04, lemp, php my admin (which works on my domain so I know that the droplet is functioning with nginx, and that nginx is serving the domain and configured (otherwise the “welcome to nginx” screen would simply pop up.

I’ve successfully compiled a lemp stack with varnish and wordpress before from source on ubuntu 14.04, with memcache phpfpm, hhvm, memcache, had a kvm that pardon my french, fuckin screamed with wordpress. finally i gave up, and tried easy engine and this is what I installed:



















I also installed ranger so I could easily look at the directory structure of the current stack, and all seems to be in order.

Here are the results:

Setting up NGINX configuration [Done]
Setting up webroot [Done]
Downloading Wordpress [Done]
Setting up database [Done]
Installing plugin nginx-helper, please wait...
Reload : nginx [OK]
WordPress admin user : james
WordPress admin user password : ************* obviously not sharing this.
Successfully created site http://flaremybiz.com

when I go to my domain, I am immediately sent to php my admin…. any thoughts?

6 Answers

I just used it for WordPress multi site and it was the most painless install experience I've ever had

Also I checked the processes in php my admin and found the following errors:

Notice in ./libraries/structure.lib.php#1589
Undefined index: DEFINER


./libraries/displaystructure.inc.php#220: PMAgetHtmlForEditView(array)
./tblstructure.php#207: requireonce(./libraries/displaystructure.inc.php)
Notice in ./libraries/structure.lib.php#1590
Undefined index: SECURITY


./libraries/displaystructure.inc.php#220: PMAgetHtmlForEditView(array)
./tblstructure.php#207: requireonce(./libraries/displaystructure.inc.php)
Notice in ./libraries/structure.lib.php#1592
Undefined index: VIEW


./libraries/displaystructure.inc.php#220: PMAgetHtmlForEditView(array)
./tblstructure.php#207: requireonce(./libraries/displaystructure.inc.php)
Notice in ./libraries/structure.lib.php#1593
Undefined index: CHECK


./libraries/displaystructure.inc.php#220: PMAgetHtmlForEditView(array)
./tblstructure.php#207: requireonce(./libraries/display_structure.inc.php)

Now this is foreign territory to me, so for me to fix these problems, which certainly seem to be the cause, what do I do to solve this? Or more importantly, based on all the info I have provided, what am I doing wrong?

I have nothing on here that is confidential or that I even care about securing right now, it’s more about getting a working copy of wordpress installed on a droplet, so anyone that is willing to help me, I will gladly provide the credentials to my droplet. I’ll even pay you.

and to be more specific a lemp droplet…i can press a button and install wordpress on lamp, but unfortunately that is not my goal.

so my thoughts are this, I’m gonna learn drupal! one click drupal lemp install. was sup. i know this is a newb giving up, but at least i’m going to learn a new and more powerful cms/portal system to add to my repertoire.

  • please contact rtcamp.com they are the people behind ee they have paid support as well

  • I'd highly suggest you take another look at Easy Engine (EE). They have easy installation scripts for 12 types of WordPress sites. I'm not at all an Easy Engine expert yet, and I do not represent rtCamp (makers of EE), but it sounds to me, by your dialogue above, things may have been done, out of order.

    Give it one more shot, with a fresh server instance and the Super-Easy instructions found here: [http://bamajr.us/easy-engine](http://)

    I'd even go as far as saying, don't start installing a bunch of software packages, until you've gone through the instructions, at the link above. Easy Engine is awesome and I'd hate for you to miss out, just because you gave up.

Have another answer? Share your knowledge.