has anyone used one of these guys tuts and succeeded?

June 20, 2015 1.3k views
Nginx WordPress

every one is outdated or purposely wrong to disallow you to install wordpress and nginx on a droplet. i have tried on every os they have and used their tuts plus my usual installations, and every single one files miserably

  • do you have an idea of what point things are failing?

    when running a server, its a really good skill to be able to trouble-shoot down to where things are failing.

    There is probably one or two points where things are going wrong.. often it can be something really simple that you will feel like kicking yourself when you realize it.

  • listen... I have no clue, all I know is that there are no errors, until I get to trying the actual site. i cannot pinpoint it, i've tried installing under the www directory and html directory and 5 different linux os distributions... my conclusion is that this host does not allow wordpress with nginx as a standalone. hence why they have a lamp one click install. my nginx.conf file should be very simple, as I have a domain, i checked the configuration 10,000 times, and it's not possible so i'm done. i heard so many great things about these guys, and i can't stand them like I'm gonna literally rip my hair out. i wasted a whole day on this stupid lousy system with a bunch of tutorials that are setup to force you to use their resources and waste money and fail.

    i'm really really upset right now, and i'm new to this type of system. whm and cpanel suck, bluehost vps sucks, as i was able to succesffully complete the install only to find out that I'm forced to use mojo. so there isn't a good host out there. i wanted these guys as they are affordable and if i could have the setup I want, I could save money and make money for these people and myself, but i cannot do it. i just need help. there tuts are all a bunch of bullshit, and they purposely change strucutre of their packages to confuse you and make you fail... eg. ubuntu 14.04 uses /html not /www and this is where i believe the hangup is coming from. even creating the directory and moving everything over does not work. i've scoured the internet for help and all i can find is digital ocean tutorials, and i can't stand them. all i want is a host that is good. with options. this was supposed to be it.

    if i see one more digital ocean tutorial, i literally will throw my mac across the room.

  • i can't even instal a droplet on top of a droplet as they claim you are able to do. so a one click lemp install, then a wordpress install onto the exisiting droplet is not possible.

    i spent so many hours attempting on every distribution they have, and it fails. it's a clean install. im not trasnferring anything other then pointing dns over here and using their nameservers at my registrar. there is nothing that should make this difficult. nothing. i've tried literally installing lemp stack from scratch, no problem. then put wordpress, drupal, joomla, or any opensource cms systems that people love, and nothing. yes they have a one click drupal lemp install. but the fact of the matter is that almost 70% of the world's websites now use wordpress.

    as a business man, and someone who has been using linux mac and windows since he was 4, this should be cake.

  • i don't want to put my config out in the open, but these are the steps i run through:





    I've tried centos 6 and debian as well.

    I have accomplished this before on ubuntu only to find out it was a waste, because you are then forced to use mojo marketplace for everything. bluehost is garbage. godaddy i dont even want to go there. i got everything up and running, and then boom... server broke every other day. so i downgraded to a straight command line install of everything so i could use ubuntu...well what do they do, prepackage it with apache. why put more of a load on a server then it needs...apache and nginx multi managing tasks... not resourceful. mpw are a pain to configure and why go through the extra work when you can have nginx server everything.

    by Etel Sverdlov
    LEMP stack is a group of open source software to get web servers up and running. The acronym stands for Linux, nginx (pronounced Engine x), MySQL, and PHP. This tutorial explains how to install the required repos to download nginx and php-fpm, how to install MySQL, how to install nginx, how to install php-fpm, how to configure php and nginx, and how to create a php info page. This tutorial is written for Ubuntu 12.04.
  • i was thinking i could just setup a load balancer over here because i don't seem to have any other options...

1 Answer

I'm kind of confused. What do you mean by they prepackage everything? When you manually install your LEMP stack and you enter your apt-get commands, the package you install is correct in that you get the correct packages from the repo's. Nginx's stable install for Ubuntu 14.04 is codenamed trusty and that is what you get... from reading through what you are saying here, it seems as though you are suggesting that DO are configuring their own packages and making you use theirs and that isn't the case, at least from my experience.


Have another answer? Share your knowledge.