Question

Have repetitively attempted to set up server to work with InstaSuite, specifically InstaMailer and keep getting same error.

Check curl

if [ -e ‘/usr/bin/curl’ ]; then curl -0 http://vestacp.com/pub/vst-install-$type.sh if [ “$?” -eq ‘0’ ]; then bash vst-install-$type.sh $* exit else echo “Error: vst-install-$type.sh download failed.” exit 1 fi fi

exit bash: yst-install.sh: No such file or directory root@impact-solutions:~#

Please Advise! This thing is driving me nuts!

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Turns out you need apache and dovecot installed so this is the amended install command line: bash vst-install.sh -f --nginx no --apache yes --remi no -k no -v no -i no -b no -z yes -t no -c no -m no -s <DOMAIN> -e <EMAIL/USER> -p <PASSWORD>

My system is up and runing now thanks to InstaSuite support stepping in and amending my setup for these 2 missing parts via my Vesta Control Panel

You might be past this now, but this may help others later…

I had the same, then found that by separating the two commands it worked - not sure if that was the issue TBH, but it helped to separate out the commands, for me. I’m installed now, but not got a successful connection with InstaMailer yet.

I ran this:

curl -O http://vestacp.com/pub/vst-install.sh

Then this:

bash vst-install.sh -f --nginx no --apache no --remi no -k no -v no -i no -b no -z no -t no -c no -m no -s <DOMAIN> -e <EMAIL/USER> -p <PASSWORD>

(this is using the short versions of the parameters - i.e. -p instead of --password. I also ommitted params where the default is to set that parameter as we need it - all to save typing!)

To verify this command line / get a full list of the short versions of the parameters, type the following at the command line:

bash vst-install.sh -h

Please check this updated guide - https://instasuite.replytap.io/articles/18195/which-is-the-most-affordable-smtp-i-can-start-with.

Also, this install command is one line, this is important. Hope this helps!