Having and issue with cyberduck ftp access?

February 8, 2016 1.6k views
FAQ Apache

I have been trying to access sftp with cyberduck but I am not sure what to enter for the information. I do not not where to find my username or my password and should i enter the ip address or the web domain?

1 Answer

Happy to help. Here are the settings you'll want to use:

Port: 22
User: root
Password: Your root password
Host/Server: Your droplet's IP address

On a newly created droplet you will not be able to make an SFTP connection until you log in via ssh or the console in the control panel. On the first login you are prompted to create a new root password to replace the temporary one that was emailed to you. After logging in this will first prompt you to enter your current password a second time and then will request that you enter a new password twice. Once you've replaced your temporary password your droplet will accept SFTP connections.

  • I can login to the console but I cannot login to ftp, I used the exact same password.

    • What messages are being displayed in CyberDuck when your connection fails?

      • Exhausted available authentication methods. Please contact your web hosting service provider for assistance.

        • That is odd. Some searching found that in Cyberduck old passwords can sometimes stick around. If you attempted to connect to this droplet previously with a different password it could be attempting to use that. Choosing save to keychain is recommended to ensure that the password is up to date.

          This is the password you set after logging into the console, correct?

          • Yes. The help desk said that i should be able to do this.

            It's likely that the SSH service has been configured to only allow 'root' to log in with an SSH key (this is the configuration option "PermitRootLogin no" or "without-password" in /etc/ssh/sshd_config). If you're able to log in at the console, you can make edits to your SSH daemon's configuration, and then restart it to allow login with a password instead of SSH keys.

            If you change these two options in /etc/ssh/sshd_config, you should be able to access the Droplet via SSH with the root user:

            PermitRootLogin yes
            PasswordAuthentication yes

            yet I have no access to the /ect it says no directory exists.

Have another answer? Share your knowledge.